
        
            
                
            
        

    Annotation
Эта книга посвящена новой версии самой популярной и мощной универсальной среды проектирования AutoCAD 2009, разработанной компанией Autodesk.

Издание предназначено для начинающего пользователя, незнакомого с методами автоматизированного геометрического моделирования и компьютерными технологиями.

Для более подробного изучения программы читателю предлагается воспользоваться книгой Т. Ю. Соколовой «AutoCAD 2009. Учебный курс», к которой прилагается компакт-диск с уникальной авторской тренинг-системой, предназначенной для изучения среды AutoCAD.
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Введение 



В настоящее время существует множество графических редакторов и программ геометрического моделирования. Компания Autodesk – один из ведущих производителей систем автоматизированного проектирования и программного обеспечения для конструкторов, дизайнеров, архитекторов. Это крупнейший в мире поставщик программного обеспечения и услуг для промышленного и гражданского строительства, машиностроения, геоинформатики, цифровых средств передачи информации и беспроводной связи, обслуживающий 7 000 000 пользователей.

Система AutoCAD, разработанная этой компанией, является лидирующей в мире платформой программного обеспечения систем автоматизированного проектирования (САПР), предназначенной для профессионалов, которым требуется воплощать свои творческие замыслы в реальные динамические проекты.

AutoCAD – программа с богатой и во многом уникальной историей. Впервые она увидела свет в 1982 году под именем MicroCAD. Первая версия AutoCAD ознаменовала начало настоящей революции в автоматизированном проектировании. Сегодня AutoCAD переводится на 18 языков, ее используют в своей работе миллионы проектировщиков во всем мире на процессорах в тысячи раз мощнее тех, которые были установлены на первых персональных компьютерах.

AutoCAD является постоянно развивающейся базовой средой проектирования, каждая новая версия которой наследует все лучшее от предыдущих и направлена на решение следующих основных задач: повышение производительности и эффективности работы пользователей; обеспечение многократного использования имеющихся наработок; беспрепятственное сотрудничество пользователей при проектировании; адаптация AutoCAD к индивидуальным потребностям разработчиков объектно-ориентированных задач.

Залог успеха Autodesk – мировое признание AutoCAD в качестве стандарта де-факто для разработки продуктов и комплектующих, а также для документации.

Используя свою стратегию, направленную на помощь заказчикам в создании, организации и распространении цифровых конструкторских данных и в решении серьезных бизнес-проблем, Autodesk предлагает наиболее полный комплект интегрированных программных инструментов двумерного и трехмерного конструирования, что позволяет создавать более качественные продукты, ускорять вывод изделий на рынок и добиваться максимальной наглядности проектов и наиболее эффективного сотрудничества.

Благодаря выпуску AutoCAD 2009 компания Autodesk предлагает архитекторам, дизайнерам, инженерам и проектировщикам новый инструмент для еще более полного воплощения их идей в реальность.


От издательства 


Ваши замечания, предложения и вопросы отправляйте по адресу электронной почты dgurski@minsk.piter.com (издательство «Питер», компьютерная редакция).

Мы будем рады узнать ваше мнение!

На сайте издательства http://www.piter.com вы найдете подробную информацию о наших книгах.


Глава 1 

AutoCAD 2009. Общие сведения 



Требования к системе 


AutoCAD может работать как в автономном режиме, так и в локальной сети. Для эффективной работы AutoCAD 2009 под управлением операционной системы Windows необходимы следующие программные и аппаратные средства:

□ процессор Intel® Pentium® IV;

□ операционные системы: Microsoft® Windows® XP Professional или Home Edition (пакет обновлений SP1 или SP2), Windows XP Tablet PC Edition (SP2) или Windows 2000 (SP3 или SP4). Рекомендуется устанавливать и эксплуатировать AutoCAD либо на операционной системе, локализованной на одном языке с программой, либо на англоязычной версии одной из перечисленных систем;

□ Microsoft® Internet Explorer 6.0 (пакет обновлений SP1 или более поздний);

□ 512 Мбайт оперативной памяти;

□ монитор VGA с разрешением не менее 1024 х 768 и поддержкой режима true color;

□ 750 Мбайт свободного места на жестком диске для установки;

□ привод компакт-дисков: любой (только для установки программы).

Требования к системе при использовании AutoCAD 2009 для концептуального проектирования:

□ процессор Intel® с тактовой частотой 3,0 ГГц и выше;

□ Windows XP Professional (пакет обновлений SP2);

□ не менее 2 Гбайт оперативной памяти;

□ 2 Гбайт свободного места на жестком диске, не считая места, необходимого для установки программы;

□ монитор с минимальным разрешением 1280 х 1024 и поддержкой режима true color;

□ графический адаптер класса рабочих станций, снабженный не менее 128 Мбайт памяти и поддерживающий технологию OpenGL.


Запуск системы AutoCAD 


Запуск AutoCAD осуществляется следующими способами:

□ на Панели задач выберите из меню Start ► Programs ► Autodesk ► AutoCAD 2009;

□ на Рабочем столе Windows дважды щелкните на пиктограмме AutoCAD 2009.

При запуске AutoCAD предлагает создать новый неименованный рисунок. Можно либо начать создавать в нем объекты, либо загрузить с диска один из уже имеющихся файлов.

При открытии ранее подготовленного рисунка всем системным переменным присваиваются значения, которые они имели в ходе последнего сеанса работы с ним. Это происходит благодаря тому, что переменные сохраняются в файле вместе с рисунком.

Если же вы начинаете работу «с нуля», следует предварительно задать ряд установок. Обычно это делается автоматически с помощью Мастера подготовки Wizard Description. AutoCAD позволяет менять установки и в ходе сеанса, если возникает такая необходимость.


Начало работы 


После запуска AutoCAD выводится диалоговое окно начала работы Startup (рис. 1.1).

В диалоговом окне Startup пользователю предлагается четыре кнопки, в зависимости от выбора которых меняется содержимое диалогового окна:


Open a Drawing – для открытия ранее созданного чертежа;


Start from Scratch – для создания чертежа, где устанавливаются только единицы измерения в области Default Settings: британские (футы и дюймы) или метрические (миллиметры);


Use a Template – для создания чертежа по шаблону – документу, установки которого используются как основа для нового рисунка;


Use a Wizard – вызов Мастера для установки параметров нового чертежа.

 

Рис. 1.1. Диалоговое окно начала работы

 

Вызов справочной системы 



В любой момент работы с AutoCAD вы можете получить доступ к электронной документации по программе. Для этого необходимо выбрать в падающем меню пункт Help. Альтернативный вариант – нажать клавишу F1 на функциональном блоке клавиатуры, ввести символ? в командную строку или щелкнуть на пиктограмме со значком вопроса на стандартной панели инструментов.


Открытие рисунков 


Программа AutoCAD по умолчанию записывает внутреннее представление рисунка в файл с расширением DWG.

AutoCAD предлагает многооконную среду проектирования Multiple Design Environment (MDE), которая допускает одновременное открытие нескольких чертежей.


Открыть существующий рисунок можно с помощью команды OPEN, которая вызывается из падающего меню File ► Open... или щелчком на пиктограмме Open...Ctrl+О на стандартной панели инструментов.

После обращения к команде OPEN на экране AutoCAD появляется диалоговое окно выбора файла Select File (рис. 1.2). Здесь можно выбрать имя файла из списка или ввести это название в поле File name:

 

Рис. 1.2. Диалоговое окно выбора файла

 
При выделении в списке одного из файлов в области Preview появляется соответствующий образец рисунка. Нажатие кнопки Views выводит список, изменяя параметры которого пользователь может выбрать форму представления файлов, предлагаемых для открытия: список, таблицу, образцы.

Для открытия рисунка можно дважды щелкнуть на имени соответствующего файла в Проводнике Windows, что приведет к автоматическому запуску AutoCAD. Если же в системе уже ведется сеанс работы в AutoCAD, то рисунок откроется в нем.

Рисунки, созданные в AutoCAD любой предшествующей версии, открываются как любой документ версии 2009 и автоматически преобразуются в новый формат.


Создание рисунков 



Создать новый рисунок позволяет команда NEW, вызываемая из падающего меню File ► New... или щелчком на пиктограмме QNew на стандартной панели инструментов.

После запуска команды необходимые настройки параметров рабочей среды AutoCAD производятся в диалоговом окне создания нового рисунка Create New Drawing – рис. 1.3.

 

Рис. 1.3. Диалоговое окно создания нового рисунка

 
В AutoCAD имеется так называемый Мастер подготовки Wizard – служебное средство для создания нового рисунка.

Для вызова Мастера подготовки необходимо в диалоговом окне Create New Drawing щелкнуть на пиктограмме Use a Wizard.

Мастер быстрой подготовки QuickSetup позволяет задать для нового рисунка единицы измерения Units и область рисования Area. Поддерживаются следующие типы единиц для рисования и вычерчивания: десятичные – Decimal, инженерные – Engineering, архитектурные – Architectural, дробные – Fractional, научные – Scientific.

Указывая ширину Width и длину Length области рисования, пользователь тем самым задает граничные пределы рисунка, так называемые лимиты. Именно лимитами определяется размер чертежа, впоследствии выводимого на плоттер.

Мастер детальной подготовки Advanced Setup позволяет задать для нового рисунка тип линейных единиц измерения Units и способ измерения углов Angle, указать начало отсчета угла Angle Measure и направление измерения угла Angle Direction, определить границы области рисунка Area.

Любая из установок, произведенных в начале рисования, в дальнейшем может быть изменена.


Определение границ рисунка 


Команда LIMITS позволяет установить границы текущего рисунка. Она вызывается из падающего меню Format ► Drawing Limits.

Границы рисунка – это пара двумерных точек в мировой системе координат: координаты левого нижнего и правого верхнего углов, определяющие прямоугольную область. По оси Z границы не устанавливаются.

Запросы команды LIMITS:

Reset Model space limits: – переустановка лимитов пространства модели

Specify lower left corner or [ON/OFF] <current>: – левый нижний угол

Specify upper right corner <current>: – правый верхний угол

Лимиты должны полностью охватывать полномасштабную модель.


Определение параметров сетки 


Сеткой называется упорядоченная последовательность точек, покрывающих область рисунка в пределах лимитов. Работа в режиме GRID подобна наложению на рисунок листа бумаги в клетку. Использование сетки помогает выравнивать объекты и оценивать расстояние между ними. Сетку можно включать и отключать в ходе выполнения других команд. На печать она не выводится.

Включение сетки и определение ее частоты осуществляется на вкладке Snap and Grid диалогового окна режимов рисования Drafting Settings (рис. 1.4), которое загружается из падающего меню TooLs ► Drafting Settings. .. или при выборе пункта настройки Settings... контекстного меню, вызываемого щелчком правой кнопкой мыши на кнопке Grid Display в строке состояния.

Сетка включается при установке флажка Grid On (F7). В области Grid spacing устанавливается частота горизонтальных и вертикальных делений сетки, то есть шаг сетки по осям X и Y. Это осуществляется в текстовых полях Grid X spacing: и Grid Y spacing: соответственно. В поле Major line every: устанавливается шаг основной линии.


При работе с рисунком включать и отключать сетку следует щелчком на кнопке Grid Display в строке состояния или нажатием функциональной клавиши F7.

 

Рис. 1.4. Диалоговое окно определения параметров сетки и шага привязки

 

Определение шага привязки 


В режиме шаговой привязки SNAP курсор может находиться только в определенных точках согласно установленному значению шага и при этом движется не плавно, а скачкообразно между узлами воображаемой сетки, как бы «прилипая» к ее узлам.

Шаговая привязка обычно используется для точного указания точек с помощью мыши. Интервал привязки задается отдельно по осям X и Y.

Шаг привязки не обязательно совпадает с частотой сетки. Сетку часто делают достаточно редкой, используя ее исключительно для наглядности, а шаг привязки устанавливают меньшим. Допустимо и обратное: установка большего по сравнению с сеткой шага привязки.

Включение шаговой привязки SNAP и настройка ее параметров осуществляются на вкладке Snap and Grid диалогового окна режимов рисования Drafting Settings, которое загружается из падающего меню Tools ► Drafting Settings... или при выборе пункта Settings... из контекстного меню, вызываемого щелчком правой кнопкой мыши на кнопке Snap Mode в строке состояния.

Шаговая привязка включается при установке флажка Snap On (F9). В области Snap spacing задается шаг привязки по горизонтали и вертикали. Это осуществляется в текстовых полях Snap X spacing: и Snap Y spacing: соответственно.

Тип привязки устанавливается в области Snap type. Grid snap – шаговая привязка (Rectangular snap – ортогональная, Isometric snap – изометрическая), PolarSnap – полярная привязка.


При работе с рисунком включать и отключать шаговую привязку следует щелчком на кнопке Snap Mode в строке состояния или нажатием функциональной клавиши F9.


Сохранение рисунков 



Команда сохранения рисунка QSAVE вызывается из падающего меню File ► Save или щелчком на пиктограмме Save Ctrl+S на стандартной панели инструментов.

Команды SAVE и SAVEAS предназначены для сохранения рисунка под другим именем. Команда SAVE может вызываться только из командной строки, а SAVEAS – из падающего меню File ► Save As.... В обоих случаях имя документа задается в поле File name: диалогового окна Save Drawing As – рис. 1.5.

 

Рис. 1.5. Диалоговое окно сохранения рисунка

 
Предыдущей копии рисунка на диске присваивается расширение BAK вместо DWG. Все предыдущие BAK-файлы с данным именем удаляются. Обновленный рисунок записывается с расширением DWG. Если при указании имени файла оказывается, что рисунок с таким названием уже существует, выдается предупреждение и предоставляется возможность перезаписать файл или ввести другое имя.


Получение твердой копии рисунка 



Перед выводом рисунка на плоттер можно предварительно просмотреть, как он будет размещаться на листе бумаги. Для этого используется команда предварительного просмотра PREVIEW, вызываемая из падающего меню File ► Plot Preview или щелчком на пиктограмме Plot Preview на стандартной панели инструментов.


Все установки вывода рисунка на плоттер осуществляются в диалоговом окне Plot – Model (рис. 1.6), Это окно загружается командой PLOT, вызываемой из падающего меню File ► Plot... или щелчком на пиктограмме Plot_CtrL+P на стандартной панели инструментов.

 

Рис. 1.6. Диалоговое окно вывода на печать пространства модели

 

Выход из AutoCAD 


Для выхода из AutoCAD используется команда QUIT, которая вызывается из падающего меню File ► Exit Ctrl+Q.

Команда позволяет сохранить или проигнорировать сделанные в рисунке изменения и выйти из AutoCAD. Если все выполненные изменения сохранены, при выходе из программы не появится никаких дополнительных сообщений. В противном случае на экран будет выведено диалоговое окно AutoCAD, предлагающее пользователю выбор: сохранить изменения, отказаться от них или продолжить сеанс работы. Если текущему рисунку не было присвоено имя и вы хотите сохранить рисунок, откроется диалоговое окно Save Drawing As.


Глава 2 

Пользовательский интерфейс AutoCAD 



На рис. 2.1. показан классический рабочий стол AutoCAD для Windows.

 

Рис. 2.1. Рабочий стол AutoCAD

 
В данный рабочий стол включены:

□ падающие меню Menu Browser – меню, появляющееся при щелчке на кнопке A в верхнем левом углу окна программы;

□ необязательные панели инструментов: стандартная панель Standard и панель стилей Styles – верхняя строка окна программы; панель рабочих пространств Workspaces, слоев Layers и свойств Properties – вторая строка; панель рисования Draw и редактирования Modify – столбцы слева и справа; инструментальная палитра Tool Palettes – в правой части окна программы;

□ строка состояния – строка внизу окна программы;

□ окно командных строк – выше строки состояния;

□ графическое поле, занимающее остальную часть рабочего стола.


Падающие меню 


Строка падающих меню по умолчанию содержит следующие пункты:

□ File – команды работы с файлами: создание, открытие, сохранение, публикация в Интернете, печать, экспорт файлов в другие форматы, а также диспетчеры параметров листов, плоттеров, стилей печати и пр.;

□ Edit – инструменты для редактирования частей графического поля рабочего стола программы, работы с буфером обмена и пр.;

□ View – управление экраном, зумирование, панорамирование, установка трехмерной точки зрения, создание видовых экранов и именованных видов, установка визуальных стилей, тонирование, анимация траектории перемещения, установка необходимых панелей инструментов;

□ Insert – команды вставки блоков, внешних объектов, объектов других приложений;

□ Format – команды работы со слоями и их инструментами; цветом, типами линий; управление стилями текста, размеров, мультилиний, таблиц; видом маркера точки; установки единиц измерения, границ чертежа;

□ Tools – управление рабочими пространствами; палитрами; установка порядка прорисовки объектов и получение сведений о них; работа с блоками и их атрибутами; работа с языком AutoLISP; работа с пользовательской системой координат; настройка стандартов оформления; управление Мастерами (публикации в Интернете, установки плоттеров, создания таблиц стилей печати, цветозависимых стилей печати, компоновки листа, создания подшивки, импорта параметров печати); установка параметров черчения и привязок с помощью диалоговых окон и пр.;

□ Draw – команды двумерного и трехмерного рисования;

□ Dimension – команды простановки размеров и управления параметрами размерных стилей;

□ Modify – команды редактирования элементов чертежа;

□ Window – многооконный режим работы с чертежами;

□ Help – вывод на экран системы гипертекстовых подсказок.


Панели инструментов 


Команды AutoCAD на панелях инструментов представлены в виде пиктограмм. Если задержать указатель мыши на пиктограмме, рядом с ней появляется название соответствующей команды, помещенное в маленький прямоугольник.

Если в правом нижнем углу пиктограммы изображен маленький черный треугольник, это значит, что она содержит подменю с набором родственных команд. Для вызова подменю необходимо на некоторое время задержать на пиктограмме указатель мыши, нажав ее левую кнопку.


Стандартная панель инструментов 


Стандартная панель Standard показана на рис. 2.2.

 

Рис. 2.2. Стандартная панель инструментов

 
Она содержит следующие инструменты:


QNew – создание нового файла рисунка;


Open… (Ctrl+О) – загрузка существующего файла;


Save (Ctrl+S) – сохранение текущего файла;


Plot… (Ctrl+P) – вывод рисунка на плоттер, принтер или в файл;


Plot Preview – предварительный просмотр чертежа перед выводом на печать, позволяющий увидеть размещение чертежа на листе бумаги;


Publish… – публикация листов чертежа в формате файла Design Web Format (DWF), загрузка диалогового окна Publish;


3DDWF – экспорт трехмерной модели в формате файла Design Web Format (DWF);


Cut (Ctrl+X) – копирование объектов в буфер обмена с удалением их из рисунка;


Copy (Ctrl+C) – копирование выбранных элементов чертежа в буфер Windows без удаления их из исходного документа;


Paste (Ctrl+V) – вставка данных из буфера Windows;


Match Properties – копирование свойств заданного объекта другому объекту;


Block Editor – редактирование блоков;


Undo (Ctrl+Z) – отмена последнего действия;


Redo (Ctrl+Y) – восстановление только что отмененного действия;


Pan Realtime – перемещение изображения на текущем видовом экране в режиме реального времени;


Zoom Realtime – увеличение или уменьшение видимого размера объектов на текущем видовом экране в режиме реального времени;


Подменю Zoom – раскрывающийся набор инструментов, в котором можно задать различные способы увеличения и уменьшения видимого размера объектов на текущем видовом экране;


Zoom Previous – возврат к показу предыдущего вида;


Properties (Ctrl+1) – загрузка палитры управления свойствами объектов;


DesignCenter (Ctrl+2) – диалоговый интерфейс, позволяющий быстро находить, просматривать, вызывать, переносить в текущий рисунок ранее созданные рисунки, управлять вхождениями блоков, внешними ссылками и другими элементами рисунков, такими как слои, листы и текстовые стили;


Tool Palettes Window (Ctrl+3) – инструментальные палитры в виде отдельных вкладок специального окна, которые служат эффективным средством хранения/вставки блоков и штриховки. Палитры могут содержать инструменты, предоставленные сторонними разработчиками;


Sheet Set Manager (Ctrl+4) – диспетчер подшивок наборов листов, позволяющий организовать размещение пакетов листов в зависимости от типа чертежей и с возможностью эффективного создания, управления и совместного использования наборов логически связанных рисунков;


Markup Set Manager (Ctrl+7) – диспетчер наборов пометок, позволяющий организовать работу с рисунками формата DWF;


QuickCalc (Ctrl+8) – калькулятор;


Help – вызов справочной системы.


Панель стилей 


Панель стилей Styles, показанная на рис. 2.3, предназначена для создания новых текстовых, размерных и табличных стилей.

 

Рис. 2.3. Панель стилей

 
Панель содержит следующие инструменты:


Text Style… – создание новых и редактирование имеющихся текстовых стилей;


Dimension Style… – создание новых и редактирование имеющихся размерных стилей;


Table Style… – создание новых и редактирование имеющихся табличных стилей;


Multileader Style… – создание новых и редактирование имеющихся стилей линий-выносок.


Панель рабочих пространств 


Панель Workspaces, показанная на рис. 2.4, позволяет задавать параметры рабочих пространств.

 

Рис. 2.4. Панель рабочих пространств

 
Рабочие пространства включают только необходимые наборы меню, инструментальные панели и палитры, сгруппированные и упорядоченные соответственно решаемой задаче. Элементы интерфейса, не являющиеся необходимыми для решения текущей задачи, скрываются, максимально освобождая область экрана, доступную для работы.

В AutoCAD определены следующие рабочие пространства:

□ 2D Drafting & Annotation – двумерное моделирование;

□ 3D Modeling – трехмерное моделирование;

□ AutoCAD Classic – классический AutoCAD.

Помимо возможности установить рабочее пространство, в панель Workspaces включены следующие пункты, осуществляющие:

□ Save Current As… – открытие диалогового окна Save Workspace, позволяющего сохранить текущее рабочее пространство;

□ Workspace settings… – открытие диалогового окна Workspace Settings, позволяющего настроить текущие параметры рабочего пространства для последующего использования;

□ Customize… – открытие диалогового окна Customize User Interface, позволяющего осуществить настройки интерфейса пользователя.

А также панель Workspaces содержит следующие инструменты:


Workspace Settings… – открытие диалогового окна Workspace Settings, позволяющего настроить текущие параметры рабочего пространства для последующего использования;


My Workspace – возвращение имени текущего рабочего пространства в интерфейс командной строки и установление этого пространства текущим.


Панель слоев 


Панель слоев Layers, показанная на рис. 2.5, обеспечивает работу со слоями.

 

Рис. 2.5. Панель слоев

 
В нее входят следующие инструменты:


Layer Properties Manager – вызов Диспетчера свойств слоев Layer Properties Manager;


Filter applied – раскрывающийся список управления слоями. Каждая строка содержит пиктограммы управления свойствами слоя или отображения его свойств, а также его имя. Ниже перечисляются эти пиктограммы (слева направо): Turn a layer On or Off – включение/отключение слоя; Freeze or thaw in ALL viewports – замораживание/размораживание на всех видовых экранах; Freeze or thaw in current viewport – замораживание/размораживание на текущем видовом экране; Lock or Unlock a layer – блокирование/разблокирование слоя; Color of layer – цвет слоя; Filter applied – имя слоя;


Make Object’s Layer Current – установка текущего слоя в соответствии со слоем выбранного примитива;


Layer Previous – возврат к предыдущему состоянию слоев;


Layer States Manager – загрузка диалогового окна Layer States Manager.


Панель свойств объектов 


Панель свойств объектов Properties, показанная на рис. 2.6, предназначена для работы с цветом, типом и весом линий.

 

Рис. 2.6. Панель свойств объектов

 
В нее входят следующие инструменты:


Color Control – раскрывающийся список установки текущего цвета, а также изменения цвета выбранных объектов;


Line Type Control – раскрывающийся список установки текущего типа линии, а также изменения типа линии для выбранных объектов;


Line Weight Control – раскрывающийся список установки текущего веса (толщины) линии, а также изменения толщины линий выбранных объектов;


Plot Styles Control – раскрывающийся список установки стилей печати.


Строка состояния 


Строка состояния (рис. 2.7) расположена в нижней части рабочего стола.

 

Рис. 2.7. Строка состояния

 
Она содержит текущие координаты курсора, а также кнопки включения/выключения режимов черчения:


Snap Mode – включение и выключение шаговой привязки курсора;


Grid Display – включение и выключение отображения сетки;


Ortho Mode – включение и выключение ортогонального режима;


Polar Tracking – включение и выключение режима полярного отслеживания;


Object Snap – включение и выключение режимов объектной привязки;


Object Snap Tracking – включение и выключение режима отслеживания при объектной привязке;


Allow/Disallow Dynamic UCS – включение и выключение динамической пользовательской системы координат;


Dynamic Input – включение и выключение динамического ввода;


Show/Hide Lineweight – включение и выключение режима отображения линий в соответствии с весами (толщинами);


Quick Properties – включение и выключение свойств объектов;


Model or Paper space – переключение из пространства модели в пространство листа;


Quick View Layouts – включение и выключение просмотра листов;


Quick View Drawings – включение и выключение просмотра рисунков;


Pan – панорамирование рисунка;


Zoom – зумирование рисунка;


SteeringWheel – включение инструмента Wheel;


ShowMotion – включение инструмента Motion;


Отображение кнопок включения/выключения режимов черчения в строке состояния устанавливается в контекстном меню. Для этого необходимо щелкнуть левой или правой кнопкой на инструменте Status Bar menu с изображением стрелки вниз, который находится в правом углу строки состояния.


Окно командных строк 


Окно командных строк обычно расположено над строкой состояния и служит для ввода команд и вывода подсказок и сообщений AutoCAD. По умолчанию окно команд закреплено и равно по ширине окну AutoCAD (рис. 2.8).

 

Рис. 2.8. Закрепленное окно командных строк

 
Изменить высоту окна можно с помощью разделительной полосы, находящейся в его верхней части (если оно закреплено внизу) или в нижней (если оно закреплено вверху). Чтобы изменить размер, следует захватить разделительную полосу с помощью мыши и «отбуксировать» ее до требуемой высоты.


Текстовое окно 


Просмотреть большую часть протокола команд – так называемую историю команд (command history) – можно, переключившись в текстовое окно, показанное на рис. 2.9. Оно вызывается нажатием функциональной клавиши F2 или командой TEXTSCR, а также из падающего меню View ► Display ► Text Window F2.

Текстовое окно подобно окну команд: в нем также можно вводить команды, наблюдать подсказки и сообщения, выдаваемые AutoCAD. Для перемещения по окну используются полоса прокрутки или клавиши ↑, ↓, ←, →, Page Up и пр.

Содержимое текстового окна предназначено только для чтения и не подлежит изменению, но протокол команд можно копировать для последующей вставки в командную строку или текстовый редактор.

 

Рис. 2.9. Текстовое окно

 

Контекстное меню 


Для выбора пунктов меню и пиктограмм на панели инструментов часто используется устройство указания – мышь. При работе с мышью нажатие левой кнопки в области рисования обычно применяется для выбора и указания точки на экране; щелчок правой кнопкой мыши вызывает контекстное меню, которое обеспечивает быстрый доступ к командам. Форма и содержание меню зависят от положения указателя мыши и состояния задачи.


Инструментальные палитры 



Инструментальные палитры загружаются с помощью команды TOOLPALETTES из меню Tools ► Palettes ► Tool Palettes Ctrl+3 либо щелчком на пиктограмме Tool Palettes Window (Ctrl+3) на стандартной панели инструментов.

Инструментальные палитры представляют собой отдельные вкладки, объединенные в специальном окне Tool Palettes (рис. 2.10), и являются эффективным средством хранения и вставки блоков и штриховки, а также могут содержать инструменты, предоставленные сторонними разработчиками.

 

Рис. 2.10. Инструментальная палитра

 
На палитрах удобно размещать часто используемые блоки и штриховки. Для того чтобы вставить блок или штриховку из палитры в рисунок, необходимо «захватить» элемент палитры с помощью мыши и перетащить его в графическую область.


Центр управления AutoCAD DesignCenter 


Центр управления DesignCenter предназначен для организации доступа к чертежам и их элементам и обеспечивает: просмотр содержимого чертежей на локальном диске, сетевом диске и веб-страницах; просмотр и вставку в текущий чертеж блоков, слоев, текстовых и размерных стилей, типов линий, внешних ссылок, образцов штриховки и прочих элементов чертежей; доступ к растровым изображениям и сторонним объектам, созданным в других приложениях; обновление описания блоков; перетаскивание элементов чертежа на инструментальные палитры.


Центр управления программы AutoCAD загружается командой ADCENTER, либо из падающего меню Tools ► Palettes ► DesignCenter Ctrl+2, либо щелчком на пиктограмме DesignCenter (Ctrl+2) на стандартной панели инструментов (рис. 2.11).

 

Рис. 2.11. Центр управления DesignCenter

 
Панель инструментов, расположенная вверху Центра управления DesignCenter, обеспечивает доступ к набору режимов и операций, а также осуществляет навигацию внутри окна и просмотр информации в области структуры и содержимого. Область структуры находится слева, в ней отображаются источники содержимого. Справа находится область содержимого, предназначенная для добавления элементов в чертеж или на инструментальную палитру. Область просмотра образца и пояснений к нему расположена справа внизу окна.


Глава 3 

Системы координат 



Ввод координат 


Ввод координат в AutoCAD может осуществляться двумя способами:

□ непосредственно с клавиатуры, путем указания численных значений;

□ с использованием графического маркера (курсора), который движется по экрану с помощью устройства указания. Ввод координат осуществляется щелчком левой кнопкой мыши.

Для удобства ввода координат можно использовать:

□ ортогональный режим, когда изменение координат происходит только по оси X или Y. Ортогональный режим включается либо нажатием функциональной клавиши F8, либо щелчком на кнопке


Ortho Mode в строке состояния;

□ привязку к узлам невидимой сетки, определенной с некоторым шагом по X и Y. Такую шаговую привязку можно установить либо нажав функциональную клавишу F9, либо щелкнув на кнопке


Snap Mode в строке состояния. Если включен шаг привязки, то при перемещении мыши перекрестье будет «перепрыгивать» с одного узла невидимой сетки на другой.

Значения координат независимо от способа ввода всегда связаны с некоторой системой координат. По умолчанию в AutoCAD используется так называемая мировая система координат, МСК – World Coordinate System (WCS). Она определена так, что ось OX направлена слева направо, ось OY – снизу вверх, ось OZ – перпендикулярно экрану, вовне.

Как правило, для выполнения конкретного проекта удобнее определить пользовательскую систему координат, ПСК – User Coordinate System (UCS), которую можно сместить относительно мировой и/или повернуть под любым углом. Допускается существование нескольких пользовательских систем координат, и в любой момент возможен переход от одной к другой.

Никакие изменения МСК не допускаются. AutoCAD позволяет одновременно использовать и координаты, связанные с текущей ПСК, и координаты, связанные с МСК. При этом для МСК при вводе с клавиатуры значению координат должен предшествовать символ «звездочка» (*).


Декартовы и полярные координаты 


В двумерном пространстве точка определяется в плоскости XY, которая называется также плоскостью построений. Ввод координат с клавиатуры возможен в виде абсолютных и относительных координат.

Ввод абсолютных координат производится в следующих форматах:

□ декартовы (прямоугольные) координаты. При этом для определения двумерных и трехмерных координат применяются три взаимно перпендикулярные оси: X, Y и Z. Для ввода координат указывается расстояние от точки до начала координат по каждой из этих осей, а также направление (+ или -). В начале создания нового рисунка текущей системой всегда является мировая система координат World Coordinate System (WCS), следовательно, ось X направлена горизонтально, ось Y – вертикально, а ось Z перпендикулярна плоскости XY;

□ полярные координаты. При вводе координат указывается расстояние, на котором располагается точка от начала координат, а также величина угла, образованного полярной осью и отрезком, мысленно проведенным через данную точку и начало координат. Угол задается в градусах против часовой стрелки. Значение 0 соответствует положительному направлению оси OX.

Относительные координаты задают смещение от последней введенной точки. При вводе точек в относительных координатах можно использовать любой формат записи в абсолютных координатах: @dx,dy – для декартовых, @r<А – для полярных.

Относительные декартовы координаты удобно применять в том случае, если известно смещение точки относительно предыдущей.


Пример. Построение в абсолютных координатах 



Постройте многоугольник, задавая точки в абсолютных координатах (рис. 3.1).


Запустите команду формирования отрезка LINE, вызвав ее из падающего меню Draw ► Line или щелкнув на пиктограмме Line на панели инструментов Draw. Ответьте на запросы:

_LINE

Specify first point: 40,20 – точка 1

Specify next point or [Undo]: 190,20 – точка 2

Specify next point or [Undo]: 190,100 – точка 3

Specify next point or [Close/Undo]: 130,40 – точка 4

Specify next point or [Close/Undo]: 130,100 – точка 5

Specify next point or [Close/Undo]: Close – замкните линию

 

Рис. 3.1. Построение многоугольника

 
Пример. Построение в относительных координатах 


Постройте многоугольник, задавая точки в относительных координатах (см. рис. 3.1).


Запустите команду формирования отрезка LINE, вызвав ее из падающего меню Draw ► Line или щелкнув на пиктограмме Line на панели инструментов Draw. Ответьте на следующие запросы (символ @ вводится при одновременном нажатии клавиш Shift+2):

_LINE

Specify first point: 40,20 – точка 1

Specify next point or [Undo]: @150,0 – в точку 2 относительно точки 1

Specify next point or [Undo]: @0,80 – в точку 3 относительно точки 2

Specify next point or [Close/Undo]: @-60,-60 – в точку 4 относительно точки 3

Specify next point or [Close/Undo]: @0,60 – в точку 5 относительно точки 4

Specify next point or [Close/Undo]: Close – замкните линию

Пример. Построение в полярных координатах 


Постройте многоугольник, задавая точки в полярных координатах (см. рис. 3.1).


Запустите команду формирования отрезка LINE, вызвав ее из падающего меню Draw ► Line или щелкнув на пиктограмме Line на панели инструментов Draw. Ответьте на запросы:

_LINE

Specify first point: 40,20 – точка 1

Specify next point or [Undo]: @150<0 – в точку 2 относительно точки 1

Specify next point or [Undo]: @80<90 – в точку 3 относительно точки 2

Specify next point or [Close/Undo]: @85<-135 – в точку 4 относительно точки 3

Specify next point or [Close/Undo]: @60<90 – в точку 5 относительно точки 4

Specify next point or [Close/Undo]: Close – замкните линию


Определение трехмерных координат 


Трехмерные координаты задаются аналогично двумерным, но к двум составляющим по осям X и Y добавляется третья величина – по оси Z. В трехмерном пространстве аналогично двумерному моделированию можно использовать абсолютные и относительные координаты, а также цилиндрические и сферические, которые схожи с полярными в двумерном пространстве.

При работе в трехмерном пространстве в AutoCAD все системы координат формируются по правилу правой руки. Оно определяет положительное направление оси Z трехмерной системы координат при известных направлениях осей X и Y, а также положительное направление вращения вокруг любой из осей трехмерных координат.

Для определения положительных направлений осей необходимо поднести тыльную сторону кисти правой руки к экрану монитора и направить большой палец параллельно оси X, а указательный – по оси Y. Если согнуть средний палец перпендикулярно ладони, как показано на рис. 3.2 справа, то он будет указывать положительное направление оси Z.

 

Рис. 3.2. Правило правой руки

 
Для определения положительного направления вращения следует ориентировать большой палец правой руки в положительном направлении оси и согнуть остальные пальцы, как показано на рис. 3.2, слева. Положительное направление вращения совпадает с направлением, указываемым согнутыми пальцами.


Ввод трехмерных декартовых координат 


Трехмерные декартовы координаты (x, y, z) вводятся аналогично двумерным (x, y). Дополнительно к координатам по осям X и Y необходимо ввести еще и значение по оси Z. На самом деле в AutoCAD не существует двумерных координат, и если введены значения только x и y, то это означает, что отсутствующая координата z берется по умолчанию равной нулю (системная переменная THICKNESS). При указании декартовых трехмерных координат с клавиатуры вводятся три числа через запятую, например:

3,5,2

В трехмерном пространстве, так же как и в двумерном, широко используются и абсолютные координаты (отсчитываемые от начала координат), и относительные (отсчитываемые от последней указанной точки). Признак относительных координат – символ @ перед координатами вводимой точки, которая в этом случае берется относительно последней введенной точки.


Глава 4 

Свойства примитивов 



Слои подобны лежащим друг на друге прозрачным листам кальки. На различных слоях группируются различные типы данных рисунка. Любой графический объект рисунка обладает такими свойствами, как цвет, тип и вес (толщина) линии, стиль печати. При создании объекта значения этих свойств берутся из описания слоя, на котором он создается. При необходимости свойства любого объекта можно изменить. Использование цвета позволяет различать сходные элементы рисунка. Применение линий различных типов помогает быстро распознавать такие элементы, как осевые или скрытые линии. Вес (толщина) линии определяет толщину начертания объекта и используется для повышения наглядности рисунка. Расположение объектов на различных слоях позволяет упростить многие операции по управлению данными рисунка.

Инструменты, предназначенные для работы со свойствами объектов, приведены на панелях инструментов Layers и Properties.


Разделение рисунка по слоям 


Построенные объекты всегда размещаются на определенном слое. Например, один слой может содержать несущие конструкции, стены, перегородки здания, другой слой – коммуникации, электрику и т. п., а третий – мебель, элементы дизайна и т. д. Таким образом, комбинируя различные сочетания слоев, можно компоновать необходимые комплекты конструкторской документации.

Слои могут применяться по умолчанию, а также определяться и именоваться самим пользователем. С каждым слоем связаны заданные цвет, тип, вес (толщина) линии и стиль печати. Размещая различные группы объектов на отдельных слоях, можно структурировать рисунок. Послойная организация чертежа упрощает многие операции по управлению его данными.


Управление установками свойств слоев осуществляется в Диспетчере свойств слоев Layer Properties Manager, показанном на рис. 4.1. Окно Диспетчера загружается из падающего меню Format ► Layer... или щелчком на пиктограмме Layer Properties Manager на панели инструментов Layers.

 

Рис. 4.1. Диалоговое окно управления слоями

 
При создании нового рисунка автоматически создается слой, названный 0, которому присваиваются белый цвет, непрерывный тип линии Continuous, вес (толщина) линии Default, по умолчанию соответствующий толщине 0.25 mm. Этот слой не может быть удален и переименован.

Слои обладают следующими свойствами:

□ Status – состояние слоя. Назначение слою статуса текущего;

□ Name – имя слоя. Состоит из алфавитно-цифровой информации, включающей специальные символы и пробелы;

□ On – видимость слоя. При этом на экране изображаются только те примитивы, которые принадлежат видимому слою, однако примитивы в скрытых слоях являются частью рисунка и участвуют в регенерации;

□ Freeze – замораживание слоя. Означает отключение видимости слоя при регенерации и исключение из генерации примитивов, принадлежащих замороженному слою;

□ Lock – блокировка слоя. Примитивы в блокированном слое отображаются, но их нельзя редактировать. Блокированный слой можно сделать текущим, рисовать в нем, замораживать и применять к его примитивам команды справок и объектную привязку;

□ Color – цвет примитивов заданного слоя;

□ Linetype – тип линии, которым будут отрисовываться все примитивы, принадлежащие слою;

□ Lineweight – вес (толщина) линии, которой будут отрисовываться все примитивы, принадлежащие слою;

□ Plot Style – стиль печати для заданного слоя;

□ Plot – разрешение/запрет вывода слоя на печать;

□ New VP Freeze – замораживание на видовом экране;

□ Description – описание слоя.


Для создания нового слоя необходимо щелкнуть на пиктограмме New Layer (Alt+N), которая находится в верхней части окна Диспетчера свойств слоев Layer Properties Manager, показанного на рис. 4.1.

Создается слой, по умолчанию названный Layer1. Далее все новые слои автоматически именуются Layer2, Layer3 и т. д. – в порядке их со здания. Чтобы присвоить слою уникальное имя, необходимо двойным щелчком на текущем названии активизировать поле ввода текста, а затем набрать имя с клавиатуры и нажать клавишу Enter.


Для того чтобы сделать слой текущим, необходимо установить указатель мыши в графу Status соответствующего слоя и щелкнуть на пиктограмме Set Current (Alt+C), находящейся в верхней части окна Диспетчера свойств слоев Layer Properties Manager (см. рис. 4.1).

Установить текущий слой также можно, выбрав его из раскрывающегося списка управления слоями на панели инструментов (рис. 4.2).

 

Рис. 4.2. Список управления слоями

 

Управление видимостью слоя 


AutoCAD не отображает на экране объекты, расположенные на невидимых слоях, и не выводит их на плоттер. Если при работе с деталями рисунка на одном или нескольких слоях чертеж слишком загроможден, допускается отключение или замораживание неиспользуемых слоев. Кроме того, чтобы запретить вывод на печать объектов определенных слоев, например для вспомогательных линий, можно оставить эти слои видимыми, но отключить их вывод на печать.

Для отключения слоя необходимо в Диспетчере свойств слоев Layer Properties Manager, показанном на рис. 4.1, навести указатель мыши на имя отключаемого слоя и затем щелкнуть на пиктограмме On. Аналогично происходит и замораживание слоя при щелчке на пиктограмме Freeze.

Предусмотрена возможность запрещать печать любого слоя, даже видимого. Если слой содержит, например, только справочную информацию, то его вывод на печать можно отключить. Запрещение печати слоя не изменяет его отображения на экране. Поэтому запрет печати удобно использовать для слоев, содержащих вспомогательные элементы построений. При этом перед выводом рисунка на печать такие слои не требуется отключать. Запрет печати любого слоя осуществляется в Диспетчере свойств слоев Layer Properties Manager – см. рис. 4.1. С этой целью требуется выделить слои, для которых необходимо разрешить или запретить вывод на печать, и щелкнуть на пиктограмме Plot.


Блокировка слоев 


Блокировку слоев полезно применять в случаях, когда требуется редактирование объектов, расположенных на определенных слоях, с возможностью просмотра объектов на других слоях. Редактировать объекты на заблокированных слоях нельзя. Однако они остаются видимыми, если слой включен и разморожен. Можно сделать заблокированный слой текущим и создавать на нем объекты.

Допускаются также применение на заблокированных слоях справочных команд к объектам и привязка к ним с помощью режимов объектной привязки. Заблокированные слои можно включать и отключать, а также изменять связанные с ними цвета и типы линий.

Блокировка слоя включается либо в Диспетчере свойств слоев Layer Properties Manager, показанном на рис. 4.1, либо в раскрывающемся списке управления слоями на панели инструментов Layers (см. рис. 4.2) – щелчком на пиктограмме Lock соответствующего слоя.


Цвет линии 


Назначение объектам различных цветов облегчает работу с рисунком, поскольку позволяет визуально идентифицировать группы объектов.

Присвоение цветов слоям осуществляется в Диспетчере свойств слоев Layer Properties Manager, показанном на рис. 4.1. Для этого необходимо щелкнуть на пиктограмме Color соответствующего слоя. При этом загружается диалоговое окно Select Color, предлагающее выбрать оттенок из палитры (рис. 4.3).

 

Рис. 4.3. Диалоговое окно выбора цвета

 
Кроме того, могут быть заданы ключевые слова ByLayer – по слою и ByBlock – по блоку. ByLayer означает, что примитив будет создаваться в соответствии с цветом, определенным для текущего слоя. ByBlock означает, что объекты будут изображаться белым цветом до тех пор, пока их не объединят в блок. Куда бы затем ни был вставлен блок, объекты приобретут текущий цвет.


Тип линии 


Применение различных типов линий – еще один способ визуального представления информации. Различные типы линий отражают их разное назначение. Тип линии описывается повторяющейся последовательностью штрихов, точек и пробелов. Линии сложных типов могут включать в себя различные символы. Пользователь имеет возможность создавать собственные типы линий.

Конкретные последовательности штрихов и точек, относительные длины штрихов и пробелов, а также характеристики включаемых текстовых элементов и форм определяются именем типа линии, а также его описанием.

Назначение типа линии слою осуществляется в Диспетчере свойств слоев Layer Properties Manager. Для этого необходимо щелкнуть на пиктограмме Linetype соответствующего слоя. В открывшемся диалоговом окне Select Linetype, показанном на рис. 4.4, выбирается подходящий тип линии. Если в предлагаемом списке нет нужного варианта, следует подгрузить его, щелкнув на кнопке Load... и указав в открывшемся диалоговом окне Load or Reload Linetypes подходящий образец линии. Затем, вернувшись в диалоговое окно Select Linetype, установить указатель мыши на требуемый тип линии.

 

 
Рис. 4.4. Диалоговое окно установки типа линии

Ключевое слово ByLayer означает, что примитив будет создаваться в соответствии с типом линии, определенным для текущего слоя. Ключевое слово ByBlock означает, что примитивы будут изображаться сплошными (continuous) линиями. Если эти объекты объединены в блок, им присваивается тип линии, установленный для слоя, которому принадлежит точка вставки блока.


Вес (толщина) линии 


Веса линий определяют толщину начертания объектов и используются при выводе объектов как на экран, так и на печать. Наличие линий различной толщины необходимо при оформлении чертежей: начертание линий основного контура, размеров, штриховки, невидимых линий и пр.

Для отображения на экране весов линий необходимо в строке состояния нажать кнопку LWT.

Вес линии устанавливается в Диспетчере свойств слоев Layer Properties Manager (см. рис. 4.1). Для этого необходимо щелкнуть на пиктограмме Lineweight соответствующего слоя, а затем в открывшемся диалоговом окне Lineweight выбрать из списка подходящее значение (рис. 4.5).

 

Рис. 4.5. Диалоговое окно установки веса линии

 
Веса линий можно выбирать из определенного ряда значений, среди которых есть специальный вес под названием Default. По умолчанию вес линии Default соответствует толщине 0,25 мм (0,01 дюйма).


Палитра свойств объектов 



Палитра свойств объектов Properties, показанная на рис. 4.6, – это единый инструмент, управляющий практически всеми свойствами объектов рисунка. На палитре собрано около 40 диалоговых окон и команд, которые были разрознены в более ранних версиях AutoCAD. Загружается она командой PROPERTIES, либо из падающего меню Modify ► Properties, либо щелчком на пиктограмме Properties (Ctrl+1) на стандартной панели инструментов.

Палитра свойств объектов Properties позволяет производить фильтрацию наборов выбранных объектов по их типу, предоставляя возможность редактировать свойства каждого объекта. В случае если текущий набор объектов не создан, показывается текущее состояние таких свойств рисунка, как стиль вывода на печать, ПСК, данные о видовых экранах, гиперссылки.

 

Рис. 4.6. Палитра свойств объектов

 
В верхней части палитры расположен раскрывающийся список, содержащий типы и количество выбранных объектов.

Палитра свойств объектов Properties может оставаться открытой в процессе работы; она показывает свойства выбранного объекта. Если выделено несколько объектов, в окне выводятся только общие свойства, значения которых совпадают у всех выбранных объектов. К общим свойствам относятся цвет, слой, тип линии, масштаб типа линии, стиль печати, вес линии, гиперссылка, высота.


Глава 5 

Управление экраном 



Система AutoCAD обладает широкими возможностями отображения различных видов рисунка. Предусмотрены команды, которые позволяют при редактировании чертежа быстро перемещаться от одного его фрагмента к другому для визуального контроля внесенных изменений. Можно зумировать изображение, изменяя его экранное увеличение, или производить панорамирование, перемещая рисунок по видовому экрану; также допускается сохранение выбранного вида с его последующим восстановлением для вывода на печать или просмотра. Кроме того, обеспечивается одновременный просмотр различных участков рисунка путем разделения области рисунка на несколько неперекрывающихся видовых экранов.


Зумирование 


При зумировании либо увеличивают изображение с целью большей детализации, либо уменьшают для того, чтобы на экране помещалась большая часть рисунка (рис. 5.1, 5.2).

 

Рис. 5.1. Уменьшенное изображение

 
 

Рис. 5.2. Увеличенное изображение

 
При зумировании абсолютные размеры рисунка остаются прежними – изменяется лишь размер его части, видимой в графической области.

Операция зумирования осуществляется командой ZOOM, вызываемой из падающего меню View ► Zoom (рис. 5.3) либо же со стандартной или плавающей панели инструментов Zoom (рис. 5.4).

 

Рис. 5.3. Команда зумирования в падающем меню

 
 

Рис. 5.4. Команда зумирования на стандартной и плавающей панелях инструментов

 
Команда ZOOM на стандартной панели инструментов имеет несколько исполнений. Ниже приводятся некоторые из них:


Zoom Window – определение области отображения с помощью рамки. При этом следует задать два противоположных угла прямоугольной рамки;


Zoom All – отображение всей области чертежа;


Zoom Previous – использование предыдущего вида рисунка.


Панорамирование 



Pan Realtime – панорамирование в реальном времени.

Команда PAN обеспечивает возможность интерактивного панорамирования изображения. При перемещении указателя мыши по видовому экрану происходит динамическое перемещение изображения. Для активизации функции панорамирования в реальном времени можно либо щелкнуть на кнопке Pan Realtime на стандартной панели инструментов, либо выбрать команду из падающего меню View ► Pan ► Realtime.

Чтобы изменить положение изображения на видовом экране в режиме панорамирования в реальном времени, следует перемещать указатель мыши, удерживая ее левую кнопку нажатой. Панорамирование может выполняться в одном направлении до тех пор, пока не потребуется полная регенерация изображения или не будут достигнуты лимиты рисунка. В этом случае к изображению указателя панорамирования добавляется соответствующий направлению символ-ограничитель.

Для выхода из режима панорамирования или переключения между режимами панорамирования и зумирования можно использовать контекстное меню; при этом необходимо нажать клавишу Enter или Esc.


Изменение порядка рисования объектов 



По умолчанию объекты отображаются на экране в порядке их создания. Порядок отображения можно изменить, поместив один объект перед другим. Это существенно, когда один объект перекрывает другой. Изменение порядка отображения объектов производится с помощью команды DRAWORDER, которая вызывается с панелей инструментов ModifyII и Draw Order, показанных на рис. 5.5 и 5.6, а также из падающего меню Tools ► Draw Order.

 

Рис. 5.5. Панель инструментов редактирования

 

Рис. 5.6. Панель инструментов порядка следования объектов

 
На панели Draw Order находятся следующие инструменты:


Bring to Front – размещение объекта на переднем плане;


Send to Back – размещение объекта на заднем плане;


Bring Above Objects – размещение объекта впереди заданного объекта;


Send Under Objects – размещение объекта позади заданного объекта.


Глава 6 

Точность построения объектов 



Объектная привязка координат 


Объектная привязка – наиболее быстрый способ точно указать точку на объекте, не обязательно зная ее координаты, а также построить вспомогательные линии. Например, объектная привязка позволяет построить отрезок от центра окружности, от середины сегмента полилинии, от реального или видимого пересечения объектов.

Объектную привязку можно задать в любой момент, когда AutoCAD ожидает ввода координат точки. Кроме того, имеется возможность установки одного или нескольких режимов объектной привязки в качестве текущих.

Режимы объектной привязки выбираются на плавающей панели инструментов Object Snap либо из контекстного меню, которое вызывается щелчком правой кнопкой мыши в любом месте области рисования при нажатой клавише Shift, – рис. 6.1.

В режиме объектной привязки точка помечается маркером; его форма зависит от используемого режима, имя которого появляется возле точки в виде подсказки.


Смещение 



Snap From – смещение.

Режим объектной привязки From отличается от остальных тем, что позволяет установить временную базовую точку для построения следующих точек. Обычно режим смещения используется в сочетании с другими режимами объектной привязки и относительными координатами, поскольку довольно часто требуется определить точку, у которой известны координаты относительно некоторой точки уже нарисованного объекта.

 

Рис. 6.1. Панель инструментов и контекстное меню объектной привязки

 

Конечная точка 




Snap to Endpoint – привязка к ближайшей из конечных точек объектов (отрезков, дуг и т. п.).

Пример. Привязка к конечным точкам примитивов 


Постройте отрезки, нарисованные пунктирной линией, задавая их точки с объектной привязкой к конечным точкам объектов (рис. 6.2).

Запустите команду формирования отрезка LINE, вызвав ее из падающего меню Draw ► Line или щелкнув на пиктограмме Line на панели инструментов Draw. Ответьте на запросы:

_LINE

Specify first point: ENDPOINT – укажите точку 1

Specify next point or [Undo]: ENDPOINT – укажите точку 2

Specify next point or [Undo]: – для завершения команды нажмите клавишу Enter

_LINE

Specify first point: ENDPOINT – укажите точку 3

 

Рис. 6.2. Построение с привязкой к конечным точкам

 
Specify next point or [Undo]: ENDPOINT – укажите точку 4

Specify next point or [Undo]: – для завершения команды нажмите клавишу Enter


Средняя точка 




Snap to Midpoint – привязка к средним точкам объектов (отрезков, дуг и т. п.).

Пример. Привязка к средним точкам примитивов 


Постройте отрезок, изображенный пунктирной линией, задавая его точки с объектной привязкой к средним точкам объектов (рис. 6.3).

Запустите команду формирования отрезка LINE, вызвав ее из падающего меню Draw ► Line или щелкнув на пиктограмме Line на панели инструментов Draw. Ответьте на запросы:

_LINE

Specify first point: MIDPOINT – укажите точку 1

Specify next point or [Undo]: MIDPOINT – укажите точку 2

Specify next point or [Undo]: – для завершения команды нажмите клавишу Enter

 

Рис. 6.3. Построение с привязкой к средним точкам

 

Пересечение 




Snap to Intersection – привязка к точкам пересечениий объектов (отрезков, окружностей, дуг, сплайнов и т. п.).

Пример. Привязка к точкам пересечения примитивов 


Постройте отрезок, нарисованный пунктирной линией, задавая его точки с объектной привязкой к точкам пересечения объектов (рис. 6.4).

Запустите команду формирования отрезка LINE, вызвав ее из падающего меню Draw ► Line или щелкнув на пиктограмме Line на панели инструментов Draw. Ответьте на запросы:

 

Рис. 6.4. Построение с привязкой к точкам пересечения

 
_LINE

Specify first point: INTERSECTION – укажите точку 1

Specify next point or [Undo]: INTERSECTION – укажите точку 2

Specify next point or [Undo]: – для завершения команды нажмите клавишу Enter


Точка центра 




Snap to Center – привязка к центру дуги, окружности или эллипса.

Пример. Привязка к центру окружности, дуги или эллипса 


Постройте линию, нарисованную пунктиром, задавая ее точки с объектной привязкой к центру объектов (рис. 6.5).

Запустите команду формирования отрезка LINE, вызвав ее из падающего меню Draw ► Line или щелкнув на пиктограмме Line на панели инструментов Draw. Ответьте на запросы:

_LINE

Specify first point: CENTER – укажите точку 1

Specify next point or [Undo]: CENTER – укажите точку 2

Specify next point or [Undo]: CENTER – укажите точку 3

Specify next point or [Close/Undo]: CLOSE – замкните линию

 

Рис. 6.5. Построение с привязкой к центру

 

Касательная 




Snap to Tangent – привязка к точке на дуге, окружности, эллипсе или плоском сплайне, принадлежащей касательной к другому объекту.

При выборе точки на дуге, полилинии или окружности в качестве первой точки привязки в режиме Tangent автоматически активизируется режим задержанной касательной Deferred Tangent, который может быть использован для построения окружностей по двум и трем точкам, при формировании окружности, касательной к трем другим объектам.

Пример. Построение касательной 


Постройте отрезки, нарисованные пунктирной линией, выходящие из точ ки 1 и касательные окружности (рис. 6.6).

Запустите команду формирования отрезка LINE, вызвав ее из падающего меню Draw ► Line или щелкнув на пиктограмме Line на панели инструментов Draw. Ответьте на запросы:

_LINE

Specify first point: – укажите точку 1

Specify next point or [Undo]: TANGENT – укажите точку 2

Specify next point or [Undo]: – для завершения команды нажмите клавишу Enter

_LINE

Specify first point: – укажите точку 1

Specify next point or [Undo]: TANGENT – укажите точку 3

Specify next point or [Undo]: – для завершения команды нажмите клавишу Enter

 

Рис. 6.6. Построение касательной

 

Нормаль 




Snap to Perpendicular – привязка к точке объекта, которая лежит на нормали к другому объекту или к его воображаемому продолжению.

Режим Perpendicular может использоваться для таких объектов, как отрезки, окружности, эллипсы, сплайны и дуги.

Если режим привязки Perpendicular применяется для указания первой точки отрезка или окружности, происходит построение отрезка или окружности, перпендикулярных выбранному объекту. Если должна быть указана вторая точка отрезка или окружности, AutoCAD производит привязку к точке объекта, которая принадлежит нормали, проведенной к первой указанной точке.

Пример. Построение нормали 


Постройте отрезки, нарисованные пунктирной линией, выходящие из точки 1 и перпендикулярные объектам (рис. 6.7).

Запустите команду формирования отрезка LINE, вызвав ее из падающего меню Draw ► Line или щелкнув на пиктограмме Line на панели инструментов Draw. Ответьте на запросы:

_LINE

Specify first point: – укажите точку 1

Specify next point or [Undo]: PERPENDICULAR – укажите точку 2

Specify next point or [Undo]: – для завершения команды нажмите клавишу Enter

_LINE

Specify first point: – укажите точку 1

Specify next point or [Undo]: PERPENDICULAR – укажите точку 3

Specify next point or [Undo]: – для завершения команды нажмите клавишу Enter

 

 
Рис. 6.7. Построение нормали


Ближайшая точка 



Snap to Nearest – привязка к точке на объекте, которая является ближайшей к позиции перекрестья.


Выбор режимов привязки 



Osnap Settings... – установка режима текущей объектной привязки на вкладке объектных привязок Object Snap диалогового окна режимов рисования Drafting Settings – рис. 6.8. Это окно загружается из падающего меню TooLs ► Drafting Settings... или щелчком на пиктограмме Osnap Settings... на панели инструментов Object Snap. Окно также можно загрузить, выбрав пункт Settings... из контекстного меню, которое вызывается при щелчке правой кнопкой мыши на кнопке Object Snap в строке состояния.

Если требуется несколько раз подряд произвести привязку определенного типа (например, к конечным точкам или центрам), можно задать один или несколько текущих режимов объектной привязки.

Для включения или отключения сразу всех текущих режимов объектной привязки без вызова диалогового окна Drafting Settings необходимо щелкнуть на кнопке Object Snap в строке состояния (или нажать клавиши Ctrl+F или F3). Если текущие режимы объектной привязки не заданы, автоматически вызывается диалоговое окно Drafting Settings.

 

Рис. 6.8. Диалоговое окно установки режима текущей объектной привязки

 
Если задано несколько режимов объектной привязки, AutoCAD использует режим, наиболее подходящий для выбранного объекта. Если в прицел выбора попадают две точки, удовлетворяющие заданному режиму, система производит привязку к той из них, которая лежит ближе к центру прицела.


Глава 7 

Построение линейных объектов 



Рисунки в AutoCAD строятся из набора геометрических примитивов. Под геометрическим примитивом понимается элемент чертежа, обрабатываемый системой как целое, а не как совокупность точек или объектов. Геометрические примитивы создаются командами вычерчивания или рисования, которые вызываются из падающего меню Draw или одноименной панели инструментов (рис. 7.1). Необходимо отметить, что одни и те же элементы чертежа могут быть получены по-разному, с помощью различных команд вычерчивания.

 

Рис. 7.1. Падающее меню и панель инструментов рисования

 

Точка 



Команда POINT, формирующая точку, вызывается из падающего меню Draw ► Point или щелчком на пиктограмме Point на панели инструментов Draw.

Точка определяется указанием ее координат. Запросы команды POINT:

Current point modes: PDMODE=33 PDSIZE=10.0000 – текущие режимы точек

Specify a point: – указать точку

В падающем меню предлагается два режима построения точек: Single Point – одиночная точка и Multiple Point – несколько точек. Пиктограмма Point на панели инструментов Draw использует режим построения нескольких точек.

Точки могут пригодиться, например, в качестве узлов или ссылок для объектной привязки и отсчета расстояний. Форма символа точки и его размер устанавливаются либо относительно размера экрана, либо в абсолютных единицах в диалоговом окне Point Style, которое вызывается из падающего меню Format ► Point Style....


Отрезок 


Базовым примитивом в AutoCAD является линия. Линии бывают различного рода – одиночные отрезки, ломаные (с сопряжениями дугами или без них), пучки параллельных линий (мультилинии), а также эскизные. Линии рисуют, задавая координаты точек, свойства (тип, цвет и др.), значения углов.


Команда LINE, формирующая отрезок, вызывается из падающего меню Draw ► Line или щелчком на пиктограмме Line на панели инструментов Draw.

Отрезки могут быть одиночными или объединенными в ломаную линию. Несмотря на то что сегменты соприкасаются в конечных точках, каждый из них представляет собой отдельный объект.

Запросы команды LINE:

Specify first point: – указать начало отрезка

Specify next point or [Undo]: – указать конец отрезка

Specify next point or [Undo]:

Specify next point or [Close/Undo]:

Specify next point or [Close/Undo]:

Запросы команды LINE организованы циклически. Это означает, что при построении непрерывной ломаной линии конец предыдущего отрезка служит началом следующего. При перемещении к каждой следующей точке за перекрестьем тянется «резиновая нить». Это позволяет отслеживать положение строящегося отрезка ломаной линии. Цикл заканчивается после нажатия клавиши Enter в ответ на очередной запрос Specify next point or [Close/Undo]:.

Ключи команды LINE:

□ Close – замкнуть ломаную;

□ Undo – отменить последний нарисованный отрезок.


Прямая и луч 


В AutoCAD допускается построение линий, не имеющих конца в одном или в обоих направлениях. Такие линии называются соответственно лучами и прямыми. Их можно использовать в качестве вспомогательных при построении других объектов.


Команда XLINE, формирующая прямую, вызывается из падающего меню Draw ► Construction Line или щелчком на пиктограмме Construction Line на панели инструментов Draw.

Запросы команды XLINE:

Specify a point or [Hor/Ver/Ang/Bisect/Offset]: – указать точку

Specify through point: – указать точку, через которую проходит прямая

Specify through point:

Ключи команды XLINE:

□ Hor – построение горизонтальной прямой, проходящей через заданную точку;

□ Ver – построение вертикальной прямой, проходящей через заданную точку;

□ Ang – построение прямой по точке и углу;

□ Bisect – по точке и половине угла, заданного тремя точками;

□ Offset – по смещению от базовой линии.


Команда RAY, формирующая луч, вызывается из падающего меню Draw ► Ray.

В отличие от прямых, бесконечных с обеих сторон, луч не имеет конца только в одном направлении.

Запросы команды RAY:

Specify start point: – указать первую точку

Specify through point: – указать точку, через которую проходит луч


Полилиния 




Команда PLINE, формирующая полилинию, вызывается из падающего меню Draw ► Polyline или щелчком на пиктограмме Polyline на панели инструментов Draw.

Полилиния представляет собой связанную последовательность линейных и дуговых сегментов и обрабатывается системой как графический примитив. Можно задавать ширину или полуширину отдельных сегментов, сужать полилинию или замыкать ее. При построении дуговых сегментов первой точкой дуги является конечная точка предыдущего сегмента.

Запросы команды PLINE:

Specify start point: – указать начальную точку

Current line-width is 0.0000 – текущая ширина полилинии

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: – указать следующую точку

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: – указать следующую точку

Запросы команды PLINE организованы циклически. Цикл заканчивается после нажатия клавиши Enter в ответ на очередной запрос команды.

Ключи команды PLINE:

□ Arc – обеспечивает переход в режим дуг;

□ Close – замыкает полилинию отрезком;

□ Halfwidth – позволяет задать полуширину, то есть расстояние от осевой линии широкого сегмента до края;

□ Length – задает длину сегмента, созданного как продолжение предыдущего в том же направлении;

□ Undo – отменяет последний созданный сегмент;

□ Width – позволяет задать ширину последующего сегмента.

Ключи команды PLINE в режиме построения дуг:

□ Angle – ввести центральный угол;

□ Center – указать центр дуги;

□ Close – замкнуть дугой;

□ Direction – задать направление касательной;

□ Halfwidth – определить полуширину полилинии;

□ Line – перейти в режим построения отрезков;

□ Radius – ввести радиус дуги;

□ Second pt – указать вторую точку дуги по трем точкам;

□ Undo – отменить последнюю точку;

□ Width – определить ширину полилинии.

Пример. Построение полилинии с установкой толщины 


Постройте полилинию, изображенную на рис. 7.2.

 

Рис. 7.2. Построение полилинии с установкой толщины

 
Запустите команду PLINE, вызвав ее из падающего меню Draw ► Polyline или щелкнув на пиктограмме Polyline на панели инструментов Draw. Ответьте на запросы:

_PLINE

Specify start point: 40,10 – точка 1

Current line-width is 0.0000

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: W – переход в режим установки ширины полилинии

Specify starting width <0.0000>: 0.5 – стартовая ширина

Specify ending width <0.5000>: 0.5 – конечная ширина

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: 50,12 – точка 2

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: W – переход в режим установки ширины полилинии

Specify starting width <0.5000>: 3 – стартовая ширина

Specify ending width <3.0000>: 0 – конечная ширина

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: 60,14 – точка 3

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: – для завершения команды нажмите клавишу Enter

Пример. Построение полилинии в режиме дуг 


Постройте полилинию, изображенную на рис. 7.3.

Запустите команду PLINE, вызвав ее из падающего меню Draw ► Polyline или щелкнув на пиктограмме Polyline на панели инструментов Draw.

Ответьте на запросы:

_PLINE

Specify start point: 40,8 – точка 1

Current line-width is 0.0000

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: W – переход в режим установки ширины полилинии

Specify starting width <0.0000>: 0 – стартовая ширина

Specify ending width <0.0000>: 5 – конечная ширина

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: A – переход в режим построения дуги

Specify endpoint of arc or [Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]: A – переход в режим задания углом

Specify included angle: 60 – величина угла 2

Specify endpoint of arc or [CEnter/Radius]: CE – переход в режим указания центра

Specify center point of arc: 40,24 – центр дуги 3

Specify endpoint of arc or [Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]: 65,8 – конечная точка дуги 4

Specify endpoint of arc or [Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]: – для завершения команды нажмите клавишу Enter

 

Рис. 7.3. Построение полилинии в режиме дуг

 

Многоугольник 




Команда POLYGON, обеспечивающая формирование правильного многоугольника, вызывается из падающего меню Draw ► Polygon или щелчком на пиктограмме Polygon на панели инструментов Draw.

Многоугольники представляют собой замкнутые полилинии; они могут иметь от 3 до 1024 сторон равной длины. Многоугольник можно построить, либо вписав его в воображаемую окружность, либо описав вокруг нее, либо задав начало и конец одной из его сторон. Так как длины сторон многоугольников всегда равны, с их помощью легко строить квадраты и равносторонние треугольники.

Запросы команды POLYGON:

Enter number of sides <default>: – указать количество сторон многоугольника

Specify center of polygon or [Edge]: – указать центр многоугольника

Enter an option [Inscribed in circle/Circumscribed about circle] <I>: – задать ключ размещения

Specify radius of circle: – указать радиус окружности

Ключи команды POLYGON:

□ Inscribed in circle – формирование многоугольника, вписанного в окружность;

□ Circumscribed about circle – формирование многоугольника, описанного вокруг окружности;

□ Edge – указание одной стороны.

Пример. Построение многоугольника, вписанного в окружность 


Постройте пятиугольник, вписанный в окружность (рис. 7.4).

Запустите команду POLYGON, вызвав ее из падающего меню Draw ► Polygon или щелкнув на пиктограмме Polygon на панели инструментов Draw. Ответьте на запросы:

_POLYGON

Enter number of sides <4>: 5 – количество сторон

Specify center of polygon or [Edge]: 120,60 – центр пятиугольника

Enter an option [Inscribed in circle/Circumscribed about circle] <I>: I – переход в режим формирования многоугольника, вписанного в окружность

Specify radius of circle: 50 – радиус окружности

 

Рис. 7.4. Построение вписанного многоугольника

 
Пример. Построение многоугольника, описанного вокруг окружности 


Постройте треугольник, описанный вокруг окружности (рис. 7.5).

Запустите команду POLYGON, вызвав ее из падающего меню Draw ► Polygon или щелкнув на пиктограмме Polygon на панели инструментов Draw. Ответьте на запросы:

_POLYGON

Enter number of sides <4>: 3 – количество сторон

Specify center of polygon or [Edge]: 120,60 – центр треугольника

Enter an option [Inscribed in circle/Circumscribed about circle] <I>: C – переход в режим формирования многоугольника, описанного вокруг окружности

Specify radius of circle: 50 – радиус окружности

 

Рис. 7.5. Построение описанного многоугольника

 

Прямоугольник 



Команда RECTANG формирует прямоугольник по двум противоположным углам. Вызывается из падающего меню Draw ► Rectangle или щелчком на пиктограмме Rectangle на панели инструментов Draw.

Запросы команды RECTANG:

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: – указать первый угол прямоугольника

Specify other corner point or [Area/Dimensions/Rotation]: – указать противоположный угол прямоугольника

Ключи команды POLYGON:

□ Chamfer – формирует прямоугольник со скошенными углами;

□ Elevation – задает уровень для прямоугольника;

□ Fillet – формирует прямоугольник со скругленными углами;

□ Thickness – формирует прямоугольник с заданной трехмерной высотой;

□ Width – формирует прямоугольник с заданной шириной полилинии;

□ Area – создает прямоугольник с использованием значений площади, а также значений длины или ширины;

□ Dimensions – построение прямоугольника по заданным значениям длины и ширины;

□ Rotation – создает прямоугольник под заданным углом поворота.


Глава 8 

Построение криволинейных объектов 



Дуга 




Команда ARC, формирующая дугу, вызывается из падающего меню Draw ► Arc или щелчком на пиктограмме Arc на панели инструментов Draw (рис. 8.1).

Дуги можно строить различными способами. По умолчанию построение производится путем указания трех точек: начальной, промежуточной и конечной. Дугу можно также определить, задав центральный угол, радиус, направление или длину хорды. По умолчанию дуга рисуется против часовой стрелки.

Запросы команды ARC:

Specify start point of arc or [Center]: – указать начальную точку дуги

Specify second point of arc or [Center/End]: – указать вторую точку дуги

Specify end point of arc: – указать конечную точку дуги

Ключи команды ARC:

□ Center – точка центра дуги;

□ End – конечная точка дуги;

□ Angle – величина угла;

□ chord Length – длина хорды;

□ Direction – направление касательной;

□ Radius – радиус дуги.

 

Рис. 8.1. Команда построения дуги в падающем меню

 
Существует несколько способов построения дуги при помощи команды ARC:

□ 3 Points – построение дуги по трем точкам, лежащим на дуге;

□ Start, Center, End – построение дуги по стартовой точке, центру и конечной точке дуги;

□ Start, Center, Angle – построение дуги по стартовой точке, центру и углу;

□ Start, Center, Length – построение дуги по стартовой точке, центру и длине хорды;

□ Start, End, Angle – построение дуги по стартовой точке, конечной точке и углу;

□ Start, End, Direction – построение дуги по стартовой точке, конечной точке и направлению – углу наклона касательной из начальной точки;

□ Start, End, Radius – построение дуги по стартовой точке, конечной точке и радиусу;

□ Center, Start, End – построение дуги по центру, стартовой и конечной точке;

□ Center, Start, Angle – построение дуги по центру, стартовой точке и углу;

□ Center, Start, Length – построение дуги по центру, стартовой точке и длине хорды;

□ Continue – построение дуги как продолжения предшествующей линии или дуги.

Пример. Построение дуги по трем точкам 


Постройте дугу по варианту 3 Points – рис. 8.2.

Запустите команду ARC, вызвав ее из падающего меню Draw ► Arc ► 3 Points или щелкнув на пиктограмме Arc на панели инструментов Draw. Ответьте на запросы:

_ARC

Specify start point of arc or [Center]: 50,80 – точка 1

Specify second point of arc or [Center/End]: 50,20 – точка 2

Specify end point of arc: 20,50 – точка 3

 

Рис. 8.2. Построение дуги по трем точкам

 

Окружность 




Команда CIRCLE, формирующая окружность, вызывается из падающего меню Draw ► Circle или щелчком на пиктограмме Circle на панели инструментов Draw (рис. 8.3).

Окружности можно строить различными способами. По умолчанию построение производится путем указания центра и радиуса. Можно задавать центр и диаметр или только диаметр, указывая его начальную и конечную точки. Окружность также может строиться по трем точкам. Кроме того, имеется возможность определять окружность, касающуюся либо трех объектов рисунка, либо двух (в последнем случае задается еще и радиус).

Запросы команды CIRCLE:

Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: – указать центр окружности

Specify radius of circle or [Diameter]: – указать радиус

 

Рис. 8.3. Команда построения окружности в падающем меню

 
Ключи команды CIRCLE:

□ 3Р – строит окружность по трем точкам, лежащим на окружности;

□ 2P – строит окружность по двум точкам, лежащим на диаметре;

□ Ttr – строит окружность по двум касательным и радиусу.

Пример. Построение окружности по центру и радиусу 


Постройте окружность по центру и радиусу (рис. 8.4).

Запустите команду CIRCLE, вызвав ее из падающего меню Draw ► Circle ► Center, Radius или щелкнув на пиктограмме Circle на панели инструментов Draw. Ответьте на запросы:

_CIRCLE

Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 50,50 – точка центра окружности

Specify radius of circle or [Diameter] <50>: 30 – радиус окружности

 

Рис. 8.4. Построение окружности по центру и радиусу

 
Пример. Построение окружности по двум точкам диаметра 


Постройте окружность по двум точкам диаметра (рис. 8.5).

Запустите команду CIRCLE, вызвав ее из падающего меню Draw ► Circle ► 2 Points или щелкнув на пиктограмме Circle на панели инструментов Draw. Ответьте на запросы:

_CIRCLE

Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 2P – переход в режим построения окружности по двум точкам

Specify first end point of circle’s diameter: 50,80 – точка 1

Specify second end point of circle’s diameter: 50,20 – точка 2

 

Рис. 8.5. Построение окружности по двум точкам диаметра

 

Сплайн 



Команда SPLINE, формирующая сплайн, вызывается из падающего меню Draw ► Spline или щелчком на пиктограмме Spline на панели инструментов Draw.

Сплайн представляет собой гладкую кривую, проходящую через заданный набор точек. Сплайны применяются для рисования кривых произвольной формы, например горизонталей в географических информационных системах или при проектировании автомобилей.

Запросы команды SPLINE:

Specify first point or [Object]: – указать первую точку Specify next point: – указать следующую точку

Specify next point or [Close/Fit tolerance] <start tangent>: – указать следующую точку

Specify next point or [Close/Fit tolerance] <start tangent>: – указать следующую точку

Specify next point or [Close/Fit tolerance] <start tangent>: – нажать клавишу Enter

Specify start tangent: – указать касательную в начальной точке Specify end tangent: – указать касательную в конечной точке Ключи команды SPLINE:

□ Object – преобразование полилинии в сплайн;

□ Close – замкнуть сплайн;

□ Fit tolerance – определение допуска – максимально допустимого расстояния от реального сплайна до любой из определяющих точек.


Эллипс 




Команда ELLIPSE, обеспечивающая формирование эллипса, вызывается из падающего меню Draw ► Ellipse или щелчком на пиктограмме Ellipse на панели инструментов Draw (рис. 8.6).

 

Рис. 8.6. Команда построения эллипса в падающем меню

 
По умолчанию построение эллипсов производится путем указания начальной и конечной точек первой оси, а также половины длины второй оси. Самая длинная ось эллипса называется его большой осью, самая короткая – малой.

Запросы команды ELLIPSE:

Specify axis endpoint of ellipse or [Arc/Center]: – указать конечную точку оси эллипса

Specify other endpoint of axis: – указать вторую конечную точку оси эллипса

Specify distance to other axis or [Rotation]: – указать длину другой оси

Ключи команды ELLIPSE:

□ Arc – режим построения эллиптических дуг;

□ Center – указание центра эллипса;

□ Rotation – режим построения эллипса указанием поворота относительно главной оси.

Пример. Построение эллипса по двум осям 


Постройте эллипс по конечным точкам первой оси и половине длины второй оси (рис. 8.7).

Запустите команду ELLIPSE, вызвав ее из падающего меню Draw ► Ellipse или щелкнув на пиктограмме Ellipse на панели инструментов Draw. Ответьте на запросы:

_ELLIPSE

Specify axis endpoint of ellipse or [Arc/Center]: 10,20 – начало первой оси эллипса

Specify other endpoint of axis: 80,80 – конечная точка первой оси эллипса

Specify distance to other axis or [Rotation]: 20 – половина длины второй оси эллипса

 

Рис. 8.7. Построение эллипса

 

Облако 



Команда REVCLOUD предназначена для формирования облака, вызывается из падающего меню Draw ► Revision Cloud или щелчком на пиктограмме Revision Cloud на панели инструментов Draw.

Геометрический объект «облако», использующийся для нанесения различных пояснительных надписей и пометок к элементам чертежа, представляет собой полилинию с дуговыми сегментами (рис. 8.8).

Запросы команды REVCLOUD:

Minimum arc length: 15 Maximum arc length: 15 Style: Normal – значения максимальной и минимальной длин дуги и установленный стиль

Specify start point or [Arc length/Object/Style] <Object>: – указать начальную точку или ввести ключ

Guide crosshairs along cloud path... – провести курсор по контуру облака

Revision cloud finished. – облако построено

 

Рис. 8.8. Построение облака

 
Ключи команды REVCLOUD:

□ Arc length – режим указания значения максимальной и минимальной длин дуги;

□ Object – преобразование объекта в облако;

□ Style – стиль.


Глава 9 

Построение сложных объектов 



Текстовые стили 


С каждой текстовой надписью в AutoCAD связан некоторый текстовый стиль. При нанесении надписей используется текущий стиль, в котором заданы шрифт, высота, угол поворота, ориентация и другие параметры. В одном рисунке можно создавать и использовать несколько текстовых стилей, причем их быстрое копирование из одного рисунка в другой обеспечивается благодаря Центру управления. Текстовые стили представляют собой неграфические объекты, которые также хранятся в файле рисунка. Все текстовые стили, кроме Standard, пользователь создает по своему желанию.

Команды формирования текстовых надписей, создания новых и редактирования имеющихся стилей находятся на панели инструментов Text (рис. 9.1).

 

Рис. 9.1. Инструменты формирования текстовых надписей

 

Создание и модификация текстового стиля производятся в диалоговом окне Text Style, вызываемом из падающего меню Format ► Text Style... или щелчком на пиктограмме Text Style... на панели инструментов Style (рис. 9.2).

Для создания нового стиля необходимо щелкнуть на кнопке New... – при этом будет загружено диалоговое окно New Text Style. Здесь вводится имя создаваемого стиля. Ему присваиваются значения параметров, первоначально заданные текущему текстовому стилю в окне Text Style и, как правило, нуждающиеся в изменении.

 

Рис. 9.2. Диалоговое окно текстовых стилей

 
В области Font из раскрывающегося списка SHX Font: следует выбрать подходящий шрифт, определяющий форму текстовых символов (например, simplex.shx).

В области Effects доступны следующие параметры:

□ Upside down – обеспечивает поворот текста на 180° сверху вниз симметрично горизонтальной оси;

□ Backwards – обеспечивает поворот текста на 180° слева направо симметрично вертикальной оси;

□ Vertical – обеспечивает вертикальное расположение текста, то есть символы выстраиваются один над другим;

□ в поле Width Factor: устанавливается степень сжатия/растяжения текста, то есть масштабный коэффициент;

□ в поле Oblique Angle: устанавливается угол наклона символов по отношению к нормали, причем положительным считается угол наклона вправо – по часовой стрелке, а отрицательным – влево, против часовой стрелки.


Однострочный текст 



Команда DTEXT, формирующая однострочный текст, вызывается из падающего меню Draw ► Text ► Single Line Text или щелчком на пиктограмме Single Line Text.

Команда DTEXT предназначена для создания набора строк, расположенных одна под другой. Переход к следующей строке производится нажатием клавиши Enter. Каждая строка представляет собой отдельный объект, который можно перемещать и форматировать.

Запросы команды DTEXT:

Current text style: "Standard" Text height: 2.5000 Annotative: Yes – текущий текстовый стиль и высота текста

Specify start point of text or [Justify/Style]: – указать начальную точку текста

Specify height <default>: – указать высоту текста

Specify rotation angle of text <0>: – указать угол поворота текста

далее ввести текст.

Для завершения работы команды нажать клавишу Enter после пустой строки.

Запрос определения высоты Specify height <default>: появляется только в том случае, если при описании текущего текстового стиля высота была задана равной нулю.

Ключи команды DTEXT:

□ Style – установить текущий стиль;

□ Justify – установить режим выравнивания текстовой строки с использованием ключей выравнивания.

Ключи команды DTEXT в режиме выравнивания:

□ Align – формирует вписанный текст, запрашивая его начальную и конечную точки;

□ Fit – формирует вписанный текст, выровненный по ширине и высоте;

□ Center – обеспечивает центрирование базовой линии текстовой строки относительно заданной точки;

□ Middle – обеспечивает горизонтальное и вертикальное центрирование текстовой строки относительно заданной точки;

□ Right – служит для выравнивания текстовой строки по правому краю;

□ TL – формирует текстовую строку, выровненную по верхнему и левому краям;

□ TC – формирует текстовую строку, выровненную по верхнему краю и центрированную по горизонтали;

□ TR – создает текстовую строку, выровненную по верхнему и правому краям;

□ ML – формирует текстовую строку, центрированную по вертикали и выровненную по левому краю;

□ MC – формирует текстовую строку, центрированную по вертикали и по горизонтали относительно средней точки;

□ MR – предназначен для центрирования текстовой строки по вертикали и выравнивания по правому краю;

□ BL – формирует текстовую строку, выровненную по нижнему и левому краям;

□ BC – создает текстовую строку, выровненную по нижнему краю и центрированную по горизонтали;

□ BR – формирует текстовую строку, выровненную по нижнему и правому краям.


Многострочный текст 



Команда МТЕХТ, формирующая многострочный текст, вызывается из падающего меню Draw ► Text ► Multiline Text... или щелчком кнопкой мыши на пиктограмме Multiline Text... на панели инструментов Draw.

Запросы команды MTEXT:

Current text style: "Standard" Text height: 10.0000 Annotative: Yes – текущий текстовый стиль и высота текста

Specify first corner: – указать первый угол окна абзаца

Specify opposite corner or [Height/Justify/Line spacing/Rotation/Style/Width/Columns]: – указать противоположный угол окна абзаца или соответствующий ключ

Ключи команды MTEXT:

□ Height – высота;

□ Justify – выравнивание;

□ Line spacing – межстрочный интервал;

□ Rotation – поворот;

□ Style – стиль;

□ Width – ширина;

□ Columns – колонки текста.

После указания размеров абзаца загружается редактор многострочного текста, содержащий панель форматирования текста Text Formatting и контекстное меню (рис. 9.3).

 

Рис. 9.3. Редактор многострочного текста

 

Блок 


Блоком называется совокупность связанных объектов рисунка, обрабатываемых как единый объект. Формирование часто используемых объектов может быть произведено всего один раз. Затем они объединяются в блок и при построении чертежа выполняют роль «строительных материалов». Применяя блоки, легко создавать фрагменты чертежей, которые будут неоднократно требоваться в работе.


Создание блока 



Команда BLOCK формирует блок для использования его только в текущем рисунке. Она вызывается из падающего меню Draw ► Block ► Make... или щелчком на пиктограмме Make Block на панели инструментов Draw. В результате открывается диалоговое окно Block Definition – рис. 9.4.

При создании описания блока в диалоговом окне Block Definition следует:

□ в поле Name: ввести уникальное имя создаваемого блока;

□ в области Base point задать координаты базовой точки вставки или нажать кнопку Pick point для выбора базовой точки с помощью мыши;

 

Рис. 9.4. Диалоговое окно описания блока

 
□ в области Objects выделить объекты и задать способ обработки выбранных объектов после создания описания блока;

□ в области Behavior сделать следующие настройки: Scale uniformly – одинаковый масштаб; Allow exploding – разрешить расчленение;

□ в области Settings сделать следующие настройки: в поле Block unit: установить единицы блока; с помощью кнопки Hyperlink… загрузить диалоговое окно вставки гиперссылки Insert Hyperlink;

□ в поле Description ввести текстовые пояснения для облегчения идентификации и поиска блока впоследствии;

□ Open in block editor – открыть в редакторе блоков. Описание блока сохраняется в текущем рисунке.


Вставка блока 



Команда INSERT осуществляет вставку в текущий чертеж предварительно определенных блоков или существующих файлов рисунков в качестве блока.

Команда INSERT вызывается из падающего меню Insert ► Block... или щелчком на пиктограмме Insert на панели инструментов Draw. При этом загружается диалоговое окно Insert (рис. 9.5), позволяющее настроить следующие параметры вставки блока.

 

Рис. 9.5. Диалоговое окно вставки блока

 
□ В поле Name: указывается имя вставляемого блока.

□ В области Insertion point определяется точка вставки.

□ В области Scale определяется масштаб.

□ В области Rotation определяется угол поворота.

При вставке одного рисунка в другой AutoCAD обрабатывает вставленный рисунок так же, как и обычное вхождение блока.


Разбиение блока 



Команда EXPLODE разбивает блок на составляющие его объекты.

Команда EXPLODE вызывается из падающего меню Modify ► Explode или щелчком на пиктограмме Explode на панели инструментов Modify.

При включении блока в чертеж AutoCAD обрабатывает его как графический примитив. Для обеспечения работы с его отдельными составляющими блок необходимо разбить или «взорвать». Это можно сделать и в момент вставки его в рисунок, установив в диалоговом окне Insert флажок Explode.


Глава 10 

Команды оформления чертежей 



Штриховка 



Команда ВНАТСН, формирующая ассоциативную штриховку, вызывается из падающего меню Draw ► Hatch... или щелчком на пиктограмме Hatch... на панели инструментов Draw. При обращении к команде ВНАТСН загружается диалоговое окно Hatch and Gradient, вкладка Hatch, показанное на рис. 10.1.

 

Рис. 10.1. Диалоговое окно штриховки

 
В диалоговом окне Hatch and Gradient на вкладке Hatch устанавливаются следующие параметры:

□ в области Type and pattern – тип и массив штриховки;

□ в области Angle and scale определяются: угол поворота образца штриховки, масштабный коэффициент и пр.;

□ в области Hatch origin определяется исходящая точка штриховки;

□ в области Boundaries производится определение контуров штриховки;

□ в области Options осуществляются следующие настройки: ассоциативности штриховки, создание отдельных штриховок, порядок прорисовки;

□ в области Islands определяются островки;

□ в области Boundary retention – сохранение контуров;

□ в области Boundary set определяется набор контуров;

□ в области Gap tolerance – определение допуска замкнутости в единицах чертежа;

□ в области Inherit options – наследование параметров;

□ кнопка Preview – просмотр образца перед завершением работы команды BHATCH;

□ кнопка Inherit Properties – копирование свойств.


Простановка размеров 


Размеры показывают геометрические величины объектов, расстояния и углы между ними, координаты отдельных точек. В AutoCAD используется 11 видов размеров, которые можно разделить на пять основных типов: линейные, радиальные, угловые, ординатные и длина дуги (рис. 10.2-10.6). Линейные размеры, в свою очередь, делятся на горизонтальные, вертикальные, параллельные, повернутые, ординатные, базовые и размерные цепи.

Ниже будут приведены простые примеры нанесения различных типов размеров.

Команды простановки размеров находятся в меню Dimension. Можно также воспользоваться пиктограммами на одноименной панели инструментов (рис. 10.7).

Все линии, стрелки, дуги и элементы текста, составляющие размер, будут рассматриваться как один геометрический примитив, если установлен режим ассоциативной простановки размеров.

 

Рис. 10.2. Горизонтальный, вертикальный и параллельный размеры

 

Рис. 10.3. Базовые размеры

 

Рис. 10.4. Размерные цепи

 

Рис. 10.5. Радиальные размеры

 

Рис. 10.6. Угловые размеры

 

Рис. 10.7. Падающее меню и панель инструментов Dimension

 

Линейные размеры 



AutoCAD обеспечивает несколько видов простановки линейных размеров, отличающихся углом, под которым проводится размерная линия.


Команда DIMLINEAR позволяет создавать горизонтальный, вертикальный или повернутый размеры. Команда вызывается из падающего меню Dimension ► Linear или щелчком на пиктограмме Linear на панели инструментов Dimension.

Запросы команды DIMLINEAR:

Specify first extension line origin or <select object>: – указать начало первой выносной линии

Specify second extension line origin: – указать начало второй выносной линии

Specify dimension line location or [Mtext/Text/Angle/Horizontal/Vertical/Rotated]: – указать положение размерной линии

Dimension text = измеренное значение

Если на первый запрос нажать клавишу Enter, команда DIMLINEAR выдает следующие запросы:

Specify first extension line origin or <select object>: – нажать клавишу Enter для указания объекта

Select object to dimension: – выбрать объект для нанесения размера

Specify dimension line location or [Mtext/Text/Angle/Horizontal/Vertical/Rotated]: – указать положение размерной линии

Dimension text = измеренное значение

Ключи команды DIMLINEAR:

□ Mtext – позволяет редактировать размерный текст в редакторе многострочного текста;

□ Text – позволяет редактировать размерный текст;

□ Angle – позволяет задать угол поворота размерного текста;

□ Horizontal – определяет горизонтальную ориентацию размера, отмеряет расстояние между двумя точками по оси X;

□ Vertical – определяет вертикальную ориентацию размера, отмеряет расстояние между двумя точками по оси Y;

□ Rotated – осуществляет поворот размерной и выносных линий, отмеряет расстояние между двумя точками вдоль заданного направления в текущей ПСК.

Пример. Простановка горизонтального размера 


Проставьте горизонтальный размер прямоугольника, например, как изображено на рис. 10.8.

Запустите команду DIMLINEAR, вызвав ее из меню Dimension ► Linear или щелчком на пиктограмме Linear на панели инструментов Dimension. Ответьте на запросы:

_DIMLINEAR

Specify first extension line origin or <select object>: – укажите точку 1

Specify second extension line origin: – укажите точку 2

Specify dimension line location or [Mtext/Text/Angle/Horizontal/Vertical/Rotated]: – укажите точку 3

Dimension text = 200

 

Рис. 10.8. Простановка горизонтального размера

 

Параллельный размер 




С помощью команды DIMALIGNED создается размер, параллельный измеряемой линии объекта; это позволяет выровнять размерную линию по объекту. Размер создается подобно горизонтальному, вертикальному и повернутому, при этом размерная линия расположена параллельно прямой, проходящей через размерные точки. Команда вызывается из падающего меню Dimension ► Aligned или щелчком на пиктограмме Aligned на панели инструментов Dimension.

Запросы команды DIMALIGNED:

Specify first extension line origin or <select object>: – указать начало первой выносной линии

Specify second extension line origin: – указать начало второй выносной линии

Specify dimension line location or [Mtext/Text/Angle]: – указать положение размерной линии

Dimension text = измеренное значение

Пример. Простановка параллельного размера 


Проставьте размер, параллельный измеряемой линии объекта (рис. 10.9).

Запустите команду DIMALIGNED, вызвав ее из меню Dimension ► Aligned или щелчком на пиктограмме Aligned на панели инструментов Dimension. Ответьте на запросы:

_DIMALIGNED

Specify first extension line origin or <select object>: – укажите точку 1

Specify second extension line origin: – укажите точку 2

Specify dimension line location or [Mtext/Text/Angle]: – укажите точку 3

Dimension text = 223.61


Длина дуги 



С помощью команды DIMARC создается размер длины дуги, указывающий расстояние вдоль дуги или дугового сегмента полилинии (рис. 10.10). Чтобы эти размеры отличались от линейных и угловых, для размеров длины дуги по умолчанию показан символ дуги. Команда вызывается из меню Dimension ► Arc Length или щелчком на пиктограмме Arc Length на панели инструментов Dimension.

 

Рис. 10.10. Простановка

 
Запросы команды DIMARC:

Select arc or polyline arc segment: – выбрать дугу или дуговой сегмент полилинии

Specify arc length dimension location, or [Mtext/Text/Angle/Partial/Leader]: – указать положение размера длины дуги или один из ключей

Dimension text = измеренное значение

Ключи команды DIMARC:

□ Mtext – загрузка интерфейса мультитекста;

□ Text – ввод размерного текста;

□ Angle – ввод угла поворота размерного текста;

□ Partial – режим указания положения первой и второй точек размера длины дуги;

□ Leader – режим указания размера длины дуги с линией-выноской.


Размер радиуса 




Команда DIMRADIUS, позволяющая построить радиус окружности или дуги, вызывается из падающего меню Dimension ► Radius или щелчком на пиктограмме Radius на панели инструментов Dimension.

Запросы команды DIMRADIUS:

Select arc or circle: – выбрать дугу или круг Dimension text = измеренное значение

Specify dimension line location or [Mtext/Text/Angle]: – указать положение размерной линии

По умолчанию при простановке радиуса текст начинается с символа R.

Пример. Простановка радиуса 


Проставьте два варианта радиального размера на дугу (рис. 10.11).

Запустите команду DIMRADIUS, вызвав ее из падающего меню Dimension ► Radius или щелчком на пиктограмме Radius на панели инструментов Dimension. Ответьте на запросы:

_DIMRADIUS

Select arc or circle: – укажите точку 1, лежащую на дуге

Dimension text = 90

Specify dimension line location or [Mtext/Text/Angle]: – укажите местоположение размерной линии

 

Рис. 10.11. Простановка радиуса

 

Размер диаметра 




Команда DIMDIAMETER строит диаметр окружности или дуги. Команда вызывается из падающего меню Dimension ► Diameter или щелчком на пиктограмме Diameter на панели инструментов Dimension.

Запросы команды DIMDIAMETER:

Select arc or circle: – выбрать дугу или круг

Dimension text = измеренное значение

Specify dimension line location or [Mtext/Text/Angle]: – указать положение размерной линии

При простановке размера диаметра текст по умолчанию начинается со знака


Пример. Простановка диаметра 


Проставьте два варианта диаметрального размера на окружность, как показано на рис. 10.12.

Запустите команду DIMDIAMETER, вызвав ее из падающего меню Dimension ► Diameter или щелчком пиктограмме Diameter на панели инструментов Dimension. Ответьте на запросы:

_DIMDIAMETER

Select arc or circle: – укажите точку 1, лежащую на окружности

Dimension text = 180

Specify dimension line location or [Mtext/Text/Angle]: – укажите местоположение размерной линии

 

Рис. 10.12. Простановка диаметра

 

Угловые размеры 




Команда DIMANGULAR позволяет проставить угловой размер. Она вызывается из падающего меню Dimension ► Angular или щелчком на пиктограмме Angular на панели инструментов Dimension.

Запросы команды DIMANGULAR:

Select arc, circle, line, or <specify vertex>: – выбрать дугу, круг, отрезок

Select second line: – если первое указание было отрезком, следует указать второй отрезок, непараллельный первому

Specify dimension arc line location or [Mtext/Text/Angle]: – указать положение размерной дуги

Dimension text = измеренное значение

Если в ответ на первый запрос нажата клавиша Enter, то угловой размер строится по трем точкам и команда DIMANGULAR выдает следующие запросы:

Specify angle vertex: – указать вершину угла

Specify first angle endpoint: – указать первую конечную точку угла

Specify second angle endpoint: – указать вторую конечную точку угла

Specify dimension arc line location or [Mtext/Text/Angle]: – указать положение размерной дуги

Dimension text = измеренное значение

При простановке углового размера текст по умолчанию завершается знаком градуса °.

Пример. Простановка углового размера 


Проставьте два варианта углового размера, как на рис. 10.13.

Запустите команду DIMANGULAR, вызвав ее из падающего меню Dimension ► Angular или щелчком на пиктограмме Angular на панели инструментов Dimension. Ответьте на запросы:

_DIMANGULAR

Select arc, circle, line, or <specify vertex>: – укажите точку 1

Select second line: – укажите точку 2

Specify dimension arc line location or [Mtext/Text/Angle]: – укажите местоположение размерной линии

Dimension text = 125

 

Рис. 10.13. Простановка углового размера

 

Быстрое нанесение размеров 




Команда QDIM обеспечивает быстрое нанесение размеров. Она вызывается из падающего меню Dimension ► Quick Dimension или щелчком на пиктограмме Quick Dimension на панели инструментов Dimension.

Запросы команды QDIM:

Select geometry to dimension: – выбрать объекты для нанесения размеров

Select geometry to dimension: – выбрать объекты для нанесения размеров

Select geometry to dimension: – нажать клавишу Enter для завершения выбора объектов

Specify dimension line position, or [Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datumPoint/Edit/SeTtings]<Continuous>: – запрос позволяет указать положение размерной линии

Команда QDIM запрашивает лишь указание контуров, на которые необходимо проставить размеры, и требует выбрать тип проставляемых размеров путем установки соответствующего ключа.

Пример. Быстрое нанесение размеров 


Проставьте размеры на деталь (рис. 10.14).

 

Рис. 10.14. Быстрое нанесение размеров

 
Запустите команду QDIM, вызвав ее из падающего меню Dimension ► Quick Dimension или щелчком на пиктограмме Quick Dimension на панели инструментов Dimension. Ответьте на запросы:

_QDIM

Select geometry to dimension: – укажите точку 1

Select geometry to dimension: – укажите точку 2

Select geometry to dimension: – укажите точку 3

Select geometry to dimension: – нажмите клавишу Enter для завершения выбора объектов

Specify dimension line position, or [Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datumPoint/Edit/SeT tings]<Continuous>: – укажите точку 4


Базовые размеры 



Базовые размеры – это последовательность размеров, отсчитываемых от одной базовой линии. У размерных цепей начало каждого размера совпадает с концом предыдущего. Перед построением базового размера или цепи на объекте должен быть проставлен хотя бы один линейный, ординатный или угловой размер.


Команда DIMBASELINE позволяет создавать базовые размеры. Вызывается она из падающего меню Dimension ► Baseline или щелчком на пиктограмме Baseline на панели инструментов Dimension.

Запросы команды DIMBASELINE:

Specify a second extension line origin or [Undo/Select] <Select>: – указать начало второй выносной линии

Dimension text = измеренное значение

Specify a second extension line origin or [Undo/Select] <Select>: – указать начало следующей выносной линии

Dimension text = измеренное значение

Specify a second extension line origin or [Undo/Select] <Select>: – указать начало следующей выносной линии

Dimension text = измеренное значение

Specify a second extension line origin or [Undo/Select] <Select>: – нажать клавишу Enter для окончания простановки размеров

Select base dimension: – нажать клавишу Enter для завершения работы команды

Если предыдущий размер не был линейным или если в ответ на первый запрос была нажата клавиша Enter, то предлагается выбрать линейный размер, который будет использоваться в качестве базового. При этом выдается следующий запрос:

Select base dimension: – выберите исходный размер

Далее следуют стандартные запросы команды DIMBASELINE.

Расстояние между размерными линиями в базовых размерах задается системной переменной DIMDLI.

Пример. Простановка базовых размеров 


Проставьте линейный размер, а затем от него – базовые (рис. 10.15).

 

Рис. 10.15. Простановка базовых размеров

 
Запустите команду DIMLINEAR, вызвав ее из меню Dimension ► Linear или щелчком на пиктограмме Linear на панели инструментов Dimension. Ответьте на запросы:

_DIMLINEAR

Specify first extension line origin or <select object>: – укажите точку 1

Specify second extension line origin: – укажите точку 2

Specify dimension line location or [Mtext/Text/Angle/Horizontal/Vertical/Rotated]: – укажите точку 5

Dimension text = 120

Запустите команду DIMBASELINE, вызвав ее из падающего меню Dimension ► Baseline или щелчком на пиктограмме Baseline на панели инструментов Dimension. Ответьте на запросы:

_DIMBASELINE

Specify a second extension line origin or [Undo/Select] <Select>: – укажите точку 3

Dimension text = 220

Specify a second extension line origin or [Undo/Select] <Select>: – укажите точку 4

Dimension text = 270

Specify a second extension line origin or [Undo/Select] <Select>: – нажмите клавишу Enter

Select base dimension: – нажмите клавишу Enter для завершения команды


Размерная цепь 




Команда DIMCONTINUE позволяет создавать последовательную размерную цепь. Команда вызывается из падающего меню Dimension ► Continue или щелчком на пиктограмме Continue на панели инструментов Dimension.

Запросы команды DIMCONTINUE:

Specify a second extension line origin or [Undo/Select] <Select>: – указать начало второй выносной линии

Dimension text = измеренное значение

Specify a second extension line origin or [Undo/Select] <Select>: – указать начало следующей выносной линии

Dimension text = измеренное значение

Specify a second extension line origin or [Undo/Select] <Select>: – указать начало следующей выносной линии

Dimension text = измеренное значение

Specify a second extension line origin or [Undo/Select] <Select>: – указать начало следующей выносной линии или нажать клавишу Enter

Select continued dimension: – выбрать исходный размер или нажать клавишу Enter для завершения команды

Если предыдущий размер не был линейным или если в ответ на первый запрос была нажата клавиша Enter, то предлагается выбрать линейный размер, который будет использован для продолжения. При этом выдается следующий запрос:

Select continued dimension: – выбрать исходный размер

Далее следуют стандартные запросы команды DIMCONTINUE.

Пример. Простановка последовательной размерной цепи 


Проставьте линейный размер, а затем от него – последовательную размерную цепь (рис. 10.16).

 

Рис. 10.16. Простановка последовательной размерной цепи

 
Запустите команду DIMLINEAR, вызвав ее из меню Dimension ► Linear или щелчком на пиктограмме Linear на панели инструментов Dimension. Ответьте на запросы:

_DIMLINEAR

Specify first extension line origin or <select object>: – укажите точку 1

Specify second extension line origin: – укажите точку 2

Specify dimension line location or [Mtext/Text/Angle/Horizontal/Vertical/Rotated]: – укажите точку 4

Dimension text = 100

Запустите команду DIMCONTINUE, вызвав ее из меню Dimension ► Continue или щелчком на пиктограмме Continue на панели инструментов Dimension. Ответьте на запросы:

_DIMCONTINUE

Specify a second extension line origin or [Undo/Select] <Select>: – укажите точку 3

Dimension text = 100

Specify a second extension line origin or [Undo/Select] <Select>: – нажмите клавишу Enter

Select continued dimension: – нажмите клавишу Enter для завершения работы команды


Выноски и пояснительные надписи 



Команда MLEADER, предназначенная для построения выноски, вызывается из падающего меню Dimension ► Multileader.

Запросы команды QLEADER:

Specify leader arrowhead location or [leader Landing first/Content first/Options] <Options>: – указать первую точку выноски

Specify leader landing location: – указать следующую точку выноски, а затем ввести текст

Выноской называется линия, соединяющая на рисунке пояснительную надпись с объектом, к которому она относится.

Для связи пояснительной надписи и выноски применяется короткий отрезок, который называется полкой.

Пояснительные надписи могут представлять собой многострочные тексты, рамки допусков формы и расположения поверхностей.


Управление размерными стилями 


Размерный стиль – это поименованная совокупность значений всех размерных переменных, определяющая внешний вид размера на рисунке: стиль стрелок, расположение текста и пр.


Команда DIMSTYLE обеспечивает работу с размерными стилями в диалоговом окне Dimension Style Manager – рис. 10.17. Команда вызывается из падающего меню Dimension ► Dimension Style... или щелчком на пиктограмме Dimension Style... на панели инструментов Dimension.

 

Рис. 10.17. Диалоговое окно управления размерными стилями

 
Диспетчер размерных стилей Dimension Style Manager позволяет выполнить множество различных задач:

□ Set Current – установить текущий стиль;

□ New... – создать новый размерный стиль;

□ Modify... – изменить имеющийся размерный стиль;

□ Override... – на время переопределить имеющийся размерный стиль;

□ Compare... – сравнить два размерных стиля или создать перечень всех свойств стиля;

□ воспользоваться предварительным просмотром размерных стилей рисунка и их свойств;

□ переименовать размерные стили;

□ удалить размерные стили.

Размерные стили задают внешний вид и формат размеров. Они позволяют обеспечить соблюдение стандартов и упрощают редактирование размеров. Размерный стиль определяет следующие характеристики: формат и положение размерных линий, линий-выносок, стрелок и маркеров центра; внешний вид, положение и поведение размерного текста; правила взаимного расположения текста и размерных линий; глобальный масштаб размера; формат и точность основных, альтернативных и угловых единиц; формат и точность значений допусков.

Для создания нового размерного стиля необходимо в Диспетчере размерных стилей Dimension Style Manager щелкнуть на кнопке New.... Откроется диалоговое окно Create New Dimension Style, где следует указать имя создаваемого размерного стиля.

После этого на экране появится диалоговое окно New Dimension Style (рис. 10.18).

 

Рис. 10.18. Диалоговое окно определения параметров размерного стиля, вкладка управления линиями

 
Данное окно содержит семь вкладок:

□ вкладка Lines позволяет осуществлять управление внешним видом размерных линий;

□ вкладка Symbols and Arrows позволяет настроить параметры символов и стрелок;

□ вкладка Text обеспечивает управление размерным текстом: его стилем, высотой, местоположением относительно размерной линии, зазором между текстом и размерной линией и пр.;

□ вкладка Fit позволяет установить правила взаимного расположения размерных, выносных линий и текста;

□ вкладка Primary Units позволяет определить формат и точность основных линейных и угловых единиц, вид измеренных значений размеров;

□ вкладка Alternate Units позволяет определить формат и точность альтернативных единиц, которые используются для обозначения величин размеров в дополнительной системе единиц;

□ вкладка Tolerances управляет параметрами формата и точности простановки допусков, показывающих пределы, в которых может варьироваться размер.


Глава 11 

Редактирование чертежей 



Выбор объектов 


Большинство команд редактирования AutoCAD требует предварительного указания объектов для работы с ними. Выбранные объекты – один или несколько – называются набором. Такой набор можно создать как до, так и после вызова команды редактирования.

После того как вызвана одна из команд редактирования, AutoCAD предлагает выбрать объекты. В командной строке появляется запрос:

Select objects: – выбрать объекты

При этом перекрестье указателя мыши заменяется прицелом выбора. Выбор отдельных объектов производится с помощью мыши или одним из способов. Несколько из них описаны ниже:

□ Add – включает режим добавления для пополнения существующего набора. Это начальный режим, устанавливаемый для выбора объектов;

□ ALL – позволяет выбрать все примитивы, в том числе те, которые расположены на отключенных, заблокированных и замороженных слоях;

□ Crossing – секущая рамка выделяет все объекты, которые находятся внутри или пересекают контур рамки. По умолчанию в ответ на запрос Select objects: можно указать первый угол рамки, а затем второй в направлении справа налево;

□ Last – выбирает последний нарисованный объект, видимый на экране;

□ Window – выбирает объекты, которые целиком попадают в рамку. По умолчанию в ответ на запрос Select objects: можно указать первый угол рамки, а затем второй угол по диагонали от первого в направлении слева направо.


Редактирование с помощью ручек 


Выбранными объектами можно манипулировать с помощью ручек – маленьких квадратиков, которые высвечиваются в определяющих точках выбранных объектов (рис. 11.1).

 

Рис. 11.1. Примеры примитивов с ручками

 
При включенном режиме работы с ручками выбор объектов производится до редактирования, а манипуляции с ними выполняются с помощью указателя мыши или ключевых слов. Таким образом, использование ручек позволяет минимизировать обращения к меню.


Удаление и восстановление объектов 




Команда ERASE осуществляет удаление (стирание) объектов. Она вызывается из падающего меню Modify ► Erase или щелчком на пиктограмме Erase на панели инструментов Modify.

Запросы команды ERASE:

Select objects: – выбрать объекты

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для завершения работы команды

Выбор объектов, которые следует стереть, может производиться любым из доступных способов.

Для восстановления удаленных последней командой Е RAS Е объектов используется команда OOPS. Ее название – «ОЙ» – весьма удачно отражает эмоции пользователя, испытываемые в момент применения этой команды.

Пример. Удаление объектов 


Удалить из рисунка две нижние окружности и окружность в центре (рис. 11.2).

 

Рис. 11.2. Удаление объектов

 
Запустите команду ЕRASE, вызвав ее из падающего меню Modify ► Erase или щелчком на пиктограмме Erase на панели инструментов Modify.

Ответьте на запросы:

_ERASE

Select objects: W – переход в режим выбора объектов рамкой

Specify first corner: – укажите точку 1

Specify opposite corner: – укажите точку 2

Select objects: – укажите точку 3 для выбора окружности в центре

Select objects: – нажмите клавишу Enter для завершения работы команды


Копирование объектов 




Команда COPY осуществляет копирование объектов. Она вызывается из падающего меню Modify ► Сору или щелчком на пиктограмме Сору на панели инструментов Modify.

Запросы команды COPY:

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для завершения выбора объектов

Specify base point or [Displacement/mOde] <Displacement>: – указать базовую точку или перемещение

Specify second point or <use first point as displacement>: – указать вторую точку размещения копии объекта или считать перемещением первую точку

Specify second point or [Exit/Undo] <Exit>: – указать вторую точку размещения копии объекта или нажать Enter для завершения команды

Specify second point or [Exit/Undo] <Exit>:

Запрос, требующий указания точки смещения копии объекта, делается многократно. Каждое смещение определяется относительно исходной базовой точки. После получения нужного количества копий в ответ на запрос необходимо нажать клавишу Enter.

Пример. Копирование объектов 


Получить две копии детали (рис. 11.3).

 

Рис. 11.3. Копирование объектов

 
Запустите команду COPY, вызвав ее из падающего меню Modify ► Сору или щелчком на пиктограмме Сору на панели инструментов Modify. Ответьте на запросы:

_COPY

Select objects: – укажите точку 1

Select objects: – нажмите клавишу Enter для завершения выбора объектов

Specify base point or [Displacement/mOde] <Displacement>: – укажите точку 2

Specify second point or <use first point as displacement>: – укажите точку 3

Specify second point or [Exit/Undo] <Exit>: – укажите точку 4

Specify second point or [Exit/Undo] <Exit>: – нажмите клавишу Enter для завершения работы команды


Зеркальное отображение объектов 




Команда MIRROR осуществляет зеркальное отображение объектов. Она вызывается из падающего меню Modify ► Mirror или щелчком на пиктограмме Mirror на панели инструментов Modify.

Запросы команды MIRROR:

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для завершения выбора объектов

Specify first point of mirror line: – указать первую точку оси отражения

Specify second point of mirror line: – указать вторую точку оси отражения

Delete source objects? [Yes/No] <N>: – удалить или оставить исходные объекты

Пример. Зеркальное отображение объектов 


Зеркально отобразить деталь относительно вертикальной оси, не удаляя старый объект (рис. 11.4).

 

 
Рис. 11.4. Зеркальное отображение объектов

Запустите команду MIRROR, вызвав ее из падающего меню Modify ► Mirror или щелчком на пиктограмме Mirror на панели инструментов Modify. Ответьте на запросы:

_MIRR0R

Select objects: W – переход в режим выбора объектов рамкой

Specify first corner: – укажите точку 1

Specify opposite corner: – укажите точку 2

Select objects: – нажмите клавишу Enter для завершения выбора объектов

Specify first point of mirror line: END – укажите точ ку 3 с динамической объектной привязкой к конечной точке отрезка

Specify second point of mirror line: END – укажите точ ку 4 с динамической объектной привязкой к конечной точке отрезка

Delete source objects? [Yes/No] <N>: – нажмите клавишу Enter для отказа от удаления старого объекта


Создание подобных объектов 




Команда OFFSET осуществляет создание подобных объектов (эквидистант) с заданным смещением. Она вызывается из падающего меню Modify ► Offset или щелчком на пиктограмме Offset на панели инструментов Modify.

Можно строить подобные отрезки, дуги, окружности, двумерные полилинии, эллипсы, эллиптические дуги, прямые, лучи и плоские сплайны. Подобные окружности имеют диаметр больший или меньший, чем исходный, в зависимости от того, как задано смещение. Если оно указано точкой вне окружности, то новая окружность имеет больший диаметр, а если внутри окружности – меньший.

Запросы команды OFFSET:

Specify point on side to offset or [Exit/Multiple/Undo] <Exit>:

Current settings: Erase source=No Layer=Source OFFSETGAPTYPE=0 – текущие установки команды

Specify offset distance or [Through/Erase/Layer] <Through>: – указать величину смещения

Select object to offset or [Exit/Undo] <Exit>: – выбрать объект для создания подобных

Specify point on side to offset or [Exit/Multiple/Undo] <Exit>: – указать точку, определяющую сторону смещения

Select object to offset or [Exit/Undo] <Exit>: – выбрать объект для создания подобных

Specify point on side to offset or [Exit/Multiple/Undo] <Exit>: – указать точку, определяющую сторону смещения

Select object to offset or [Exit/Undo] <Exit>: – нажать клавишу Enter для завершения команды

Ключи команды OFFSET:

□ Through – позволяет задать смещение через точку;

□ Erase – позволяет удалить исходный объект после смещения;

□ Layer – позволяет ввести параметр слоя для смещаемых объектов: текущий или источник;

□ Multiple – осуществляет создание нескольких подобных объектов (эквидистант) с заданным смещением.

Пример. Построение эквидистанты 


Построить несколько вариантов эквидистанты заданной полилинии (рис. 11.5).

 

Рис. 11.5. Построение эквидистанты

 
Запустите команду OFFSET, вызвав ее из падающего меню Modify ► Offset или щелчком на пиктограмме Offset на панели инструментов Modify. Ответьте на запросы:

_OFFSET

Specify offset distance or [Through/Erase/Layer] <Through>: 15 – смещение

Select object to offset or [Exit/Undo] <Exit>: – укажите точку 1

Specify point on side to offset or [Exit/Multiple/Undo] <Exit>: – укажите точку 2

Select object to offset or [Exit/Undo] <Exit>: – укажите точку 3

Specify point on side to offset or [Exit/Multiple/Undo] <Exit>: – укажите точку 4

Select object to offset or <exit>: – нажмите клавишу Enter для завершения работы команды


Размножение объектов массивом 



Команда ARRAY осуществляет размножение объектов массивом. Она вызывается из падающего меню Modify ► Array... или щелчком на пиктограмме Array... на панели инструментов Modify. При этом открывается диалоговое окно Array (рис. 11.6).

 

Рис. 11.6. Диалоговое окно формирования прямоугольного массива

 
В данном окне присутствуют параметры двух режимов:

□ Rectangular Array – режим установки значений прямоугольного массива;

□ Polar Array – режим установки значений кругового массива.


Перемещение объектов 




Команда MOVE осуществляет перемещение объектов. Она вызывается из падающего меню Modify ► Move или щелчком на пиктограмме Move на панели инструментов Modify.

Запросы команды MOVE:

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для завершения выбора объектов

Specify base point or [Displacement] <Displacement>: – указать базовую точку или перемещение

Specify second point or <use first point as displacement>: – указать вторую точку перемещения или считать перемещением первую точку

Пример. Перемещение объектов 


Переместите две нижние окружности так, чтобы их центры совпали с маркерами центров, обозначенными в нижней части рисунка (рис. 11.7).

 

Рис. 11.7. Перемещение объектов

 
Запустите команду MOVE, вызвав ее из падающего меню Modify ► Move или щелчком на пиктограмме Move на панели инструментов Modify.

Ответьте на запросы:

_MOVE

Select objects: W – переход в режим выбора объектов рамкой Specify first corner: – укажите точку 1

Specify opposite corner: – укажите точку 2

Select objects: – нажмите клавишу Enter для завершения выбора объектов

Specify base point or [Displacement] <Displacement>: CEN – укажите точку 3 с динамической объектной привязкой к центру левой окружности

Specify second point or <use first point as displacement : INT – укажите точку 4 с динамической объектной привязкой к пересечению отрезков маркера


Поворот объектов 




Команда ROTATE осуществляет поворот объектов. Она вызывается из падающего меню Modify ► Rotate или щелчком на пиктограмме Rotate на панели инструментов Modify.

Запросы команды ROTATE:

Current positive angle in UCS: ANGDIR=counterclockwise ANGBASE=0 – текущие установки отсчета углов в ПСК

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для завершения выбора объектов

Specify base point: – указать базовую точку

Specify rotation angle or [Copy/Reference] <0>: – указать угол поворота

Ключи команды ROTATE:

□ Copy – копировать поворачиваемый объект;

□ Reference – используется для поворота относительно существующего угла.

Пример. Поворот объектов 


Поверните деталь на 45° (рис. 11.8).

Запустите команду ROTATE, вызвав ее из падающего меню Modify ► Rotate или щелчком на пиктограмме Rotate на панели инструментов Modify. Ответьте на запросы:

_ROTATE

Current positive angle in UCS: ANGDIR=counterclockwise ANGBASE=0

Select objects: – укажите точку 1

Select objects: – нажмите клавишу Enter для завершения выбора объектов

Specify base point: CEN – укажите точку 2 с динамической объектной привязкой к центру дуги

Specify rotation angle or [Copy/Reference] <0>: 45 – угол поворота

 

Рис. 11.8. Поворот объектов

 

Масштабирование объектов 




Команда SCALE осуществляет масштабирование объектов. Она вызывается из падающего меню Modify ► Scale или щелчком на пиктограмме Scale на панели инструментов Modify.

Запросы команды SCALE:

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для завершения выбора объектов

Specify base point: – указать базовую точку

Specify scale factor or [Copy/Reference] <default>: – указать коэффициент масштабирования

Ключи команды SCALE:

□ Copy – теперь в новой версии программы у команды SCALE имеется возможность копировать масштабируемый объект;

□ Reference – применяется для определения коэффициента масштабирования с использованием размеров существующих объектов в качестве ссылок.

Пример. Масштабирование объектов 


Увеличить изображение детали в 2,5 раза (рис. 11.9).

Запустите команду SCALE, вызвав ее из падающего меню Modify ► Scale или щелчком на пиктограмме Scale на панели инструментов Modify.

Ответьте на запросы:

_SCALE

Select objects: W – переход в режим выбора объектов рамкой

Specify first corner: – укажите точку 1

Specify opposite corner: – укажите точку 2

Select objects: – нажмите клавишу Enter для завершения выбора объектов

Specify base point: – укажите точку 3

Specify scale factor or [Copy/Reference] <1.0000>: 2.5 – коэффициент масштабирования

 

Рис. 11.9. Масштабирование объектов

 

Растягивание объектов 




Команда STRETCH осуществляет растягивание объектов, сохраняя при этом связь с остальными частями рисунка. Вызывается она из падающего меню Modify ► Stretch или щелчком на пиктограмме Stretch на панели инструментов Modify.

Запросы команды STRETCH:

Select objects to stretch by crossing-window or crossing-polygon... – выбор растягиваемых объектов секущей рамкой или секущим многоугольником

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для завершения выбора объектов

Specify base point or [Displacement] <Displacement>: – указать базовую точку или перемещение

Specify second point or <use first point as displacement>: – указать вторую точку перемещения или считать перемещением первую точку

Ключ команды STRETCH:

□ Displacement – параметр перемещения, с помощью которого определяются относительное расстояние и направление.

Формирование набора объектов для этой команды должно производиться с ключом секущей рамки Crossing или Cpolygon. Любые объекты, полностью заключенные в рамку или многоугольник, перемещаются командой STRETCH точно так же, как командой MOVE.

Пример. Растягивание объектов 


Растянуть объект со смещением вправо (рис. 11.10).

 

Рис. 11.10. Растягивание объектов

 
Запустите команду STRETCH, вызвав ее из падающего меню Modify ► Stretch или щелчком на пиктограмме Stretch на панели инструментов Modify. Ответьте на запросы:

_STRETCH

Select objects to stretch by crossing-window or crossing-polygon...

Select objects: C – переход в режим выбора объектов секущей рамкой

Specify first corner: – укажите точку 1

Specify opposite corner: – укажите точку 2

Select objects: – нажмите клавишу Enter для завершения выбора объектов

Specify base point or [Displacement] <Displacement>: – укажите точку 3

Specify second point or <use first point as displacement>: – укажите точку 4


Обрезка объектов 




Команда TRIM, которая осуществляет отсечение объектов по режущей кромке, вызывается из падающего меню Modify ► Trim или щелчком на пиктограмме Trim на панели инструментов Modify.

Запросы команды TRIM:

Current settings: Projection=UCS Edge=None – текущие установки

Select cutting edges ... – выбор режущих кромок

Select objects or <select all>: – выбрать объекты, являющиеся режущей кромкой

Select objects: – нажать клавишу Enter для завершения выбора режущей кромки

Select object to trim or shift-select to extend or [Fence/Crossing/Project/Edge/eRase/Undo]: – выбрать обрезаемый объект (при использовании клавиши Shift – удлиняемый) или один из ключей

Select object to trim or shift-select to extend or [Fence/Crossing/Project/Edge/eRase/Undo]: – нажать клавишу Enter для завершения работы команды

Секущей кромкой могут служить отрезки, дуги, окружности, двумерные полилинии, эллипсы, сплайны, прямые, лучи.

Ключи команды TRIM:

□ Fence – объекты выбираются с помощью пересекающей их линии;

□ Crossing – объекты выбираются с помощью секущей рамки;

□ Project – определяет режим отсечения объектов по пересечению их проекции с границей в трехмерном пространстве;

□ Edge – определяет режим поиска пересечения по продолженной кромке другого объекта или только до объекта, который пересекает подлежащий обрезке объект в трехмерном пространстве;

□ eRase – удаление выбранных объектов.

Пример. Обрезка объектов 


Отсечь части окружности, нарисованные пунктирной линией (рис. 11.11).

Запустите команду TRIM, вызвав ее из падающего меню Modify ► Trim или щелчком на пиктограмме Trim на панели инструментов Modify. Ответьте на запросы:

_TRIM

Current settings: Projection=UCS Edge=None

Select cutting edges ...

Select objects or <select all>: – укажите точку 1

 

Рис. 11.11. Обрезка объектов

 
Select objects: – нажмите клавишу Enter для завершения выбора секущей кромки

Select object to trim or shift-select to extend or [Fence/Crossing/Project/Edge/eRase/Undo]: – укажите точку 2

Select object to trim or shift-select to extend or [Fence/Crossing/Project/Edge/eRase/Undo]: – укажите точку 3

Select object to trim or shift-select to extend or [Fence/Crossing/Project/Edge/eRase/Undo]: – нажмите клавишу Enter для завершения работы команды


Удлинение объектов 




Команда EXTEND, которая осуществляет удлинение объектов до граничной кромки, вызывается из падающего меню Modify ► Extend или щелчком на пиктограмме Extend на панели инструментов Modify.

Запросы команды EXTEND:

Current settings: Projection=UCS Edge=None – текущие установки

Select boundary edges ... – выбор граничных кромок

Select objects or <select all>: – выбрать объекты, являющиеся граничными кромками

Select objects: – нажать клавишу Enter для завершения выбора граничной кромки

Select object to extend or shift-select to trim or [Fence/Crossing/Project/Edge/Undo]: – выбрать удлиняемый объект (при использовании клавиши Shift – обрезаемый) или один из ключей

Select object to extend or shift-select to trim or [Fence/Crossing/Project/Edge/Undo]: – нажать клавишу Enter для завершения работы команды

Ключи команды EXTEND:

□ Fence – объекты выбираются с помощью пересекающей их линии;

□ Crossing – объекты выбираются с помощью секущей рамки;

□ Project – определяет режим удлинения объектов до пересечения их проекции с границей в трехмерном пространстве;

□ Edge – определяет режим продолжения кромки до воображаемого пересечения.

Пример. Удлинение объектов 


Удлинить верхнюю полилинию до границ дуги (рис. 11.12).

Запустите команду EXTEND, вызвав ее из падающего меню Modify ► Extend или щелчком на пиктограмме Extend на панели инструментов Modify. Ответьте на запросы:

_EXTEND

Current settings: Projection=UCS Edge=None

Select boundary edges ...

Select objects or <select all>: – укажите точку 1

Select objects: – нажмите клавишу Enter для завершения выбора объектов

Select object to extend or shift-select to trim or [Fence/Crossing/Project/Edge/Undo]: – укажите точку 2

Select object to extend or shift-select to trim or [Fence/Crossing/Project/Edge/Undo]: – укажите точку 3

Select object to extend or shift-select to trim or [Fence/Crossing/Project/Edge/Undo]: – укажите точку 4

Select object to extend or shift-select to trim or [Fence/Crossing/Project/Edge/Undo]: – нажмите клавишу Enter для завершения работы команды

 

Рис. 11.12. Удлинение объектов

 

Разбиение объектов на части 




Команда BREAK, которая осуществляет разрыв объектов, вызывается из падающего меню Modify ► Break или щелчком на пиктограмме Break на панели инструментов Modify.

Запросы команды BREAK:

Select objects: – выбрать объекты

Specify second break point or [First point]: – указать вторую точку разрыва

Ключ команды BREAK:

□ First point – первая точка, определенная программой автоматически, заменяется на указанную пользователем в ответ на запрос:

Specify second break point or [First point]: F – переход в режим указания первой точки

Specify first break point: – указать первую точку разрыва

Specify second break point: – указать вторую точку разрыва

В зависимости от используемых ключей разрыв можно осуществить без стирания или со стиранием части отрезка, окружности, дуги, двумерной полилинии, эллипса, сплайна, прямой или луча и некоторых других типов объектов. Для разбиения объекта можно либо выбрать объект в первой точке разрыва, а затем указать вторую точку разрыва, либо вначале просто выбрать объект, а затем произвести указание двух точек разрыва.

Программа преобразует окружность в дугу, удаляя ее часть от первой до второй точки против часовой стрелки. Чтобы разбить объект на две части, ничего не удаляя, нужно указать вторую точку, совпадающую с первой. Это можно сделать вводом @ в ответ на запрос второй точки.


Команда BREAK, которая осуществляет разрыв объектов в одной точке, вызывается щелчком на пиктограмме Break at Point на панели инструментов Modify. При этом выдаются запросы:

Select objects: – выбрать объекты

Specify second break point or [First point]: F – переход в режим указания первой точки

Specify first break point: – указать первую точку разрыва Specify second break point: @ – завершение работы команды

Пример. Разбиение объектов на части 


Разорвать и удалить часть окружности, нарисованную пунктирной линией (рис. 11.13).

Запустите команду BREAK, вызвав ее из падающего меню Modify ► Break или щелчком на пиктограмме Break на панели инструментов Modify. Ответьте на запросы:

_BREAK

Select object: – укажите точку 1

Specify second break point or [First point]: – укажите точку 2

 

Рис. 11.13. Разбиение объектов на части

 

Снятие фасок 




Команда CHAMFER осуществляет снятие фасок на объектах. Команда вызывается из падающего меню Modify ► Chamfer или щелчком на пиктограмме Chamfer на панели инструментов Modify.

Запросы команды CHAMFER:

(TRIM mode) Current chamfer Dist1 = 0.0000, Dist2 = 0.0000 – режим с обрезкой, параметры фаски

Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: – выбрать первый отрезок

Select second line or shift-select to apply corner: – выбрать второй отрезок

Ключи команды CHAMFER:

□ Undo – отмена предыдущей операции в команде снятия фаски;

□ Polyline – снятие фасок вдоль всей полилинии, то есть в каждом пересечении ее сегментов;

□ Distance – настройка длины фаски, то есть расстояния между точкой реального или воображаемого пересечения объектов и точкой, до которой удлиняется или обрезается объект при снятии фаски;

□ Angle – позволяет задать длину для первой линии и угол относительно первой линии для подрезания второй;

□ Trim – позволяет определить, следует ли обрезать линии до снятия фаски;

□ mEthod – позволяет выбрать один из методов установки размеров фасок: либо расстояниями, либо расстоянием и углом;

□ Multiple – создание фаски для кромок нескольких наборов объектов.

Пример. Снятие фасок 


Снять с детали фаски, нарисованные пунктирной линией (рис. 11.14).

Запустите команду CHAMFER, вызвав ее из падающего меню Modify ► Chamfer или щелчком на пиктограмме Chamfer на панели инструментов Modify. Ответьте на запросы:

_CHAMFER

(TRIM mode) Current chamfer Dist1 = 0.0000, Dist2 = 0.0000

Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: D – переход в режим настройки длины фаски

Specify first chamfer distance <0.0000>: 20 – первая длина фаски

 

Рис. 11.14. Снятие фасок

 
Specify second chamfer distance <20.0000>: – нажмите клавишу Enter, согласившись со значением, предлагаемым по умолчанию

Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: P – переход в режим снятия фасок с полилинии

Select 2D polyline: – укажите точку 1

4 lines were chamfered

_CHAMFER

(TRIM mode) Current chamfer Dist1 = 20.0000, Dist2 = 20.0000

Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: D – переход в режим настройки длины фаски

Specify first chamfer distance <20.0000>: 30 – первая длина фаски

Specify second chamfer distance <30.0000>: – нажмите клавишу Enter, согласившись со значением, предлагаемым по умолчанию

Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: – укажите точку 2

Select second line or shift-select to apply corner – укажите точку 3

_CHAMFER

(TRIM mode) Current chamfer Dist1 = 30.0000, Dist2 = 30.0000

Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: – укажите точку 4

Select second line or shift-select to apply corner – укажите точку 5


Рисование скруглений 




Команда FILLET осуществляет плавное округление (сопряжение) объектов. Она вызывается из падающего меню Modify ► Fillet или щелчком на пиктограмме Fillet на панели инструментов Modify.

Запросы команды FILLET:

Current settings: Mode = TRIM, Radius = 10.0000 – текущие настройки

Select first object or [Undo/Polyline/Radius/Trim/Multiple]: – выбрать первый объект

Select second object or shift-select to apply corner: – выбрать второй объект

Можно сопрягать пары отрезков, линейные (но не дуговые) сегменты полилиний, прямые, лучи, круги, дуги и реальные (то есть не многоугольные) эллипсы. Сопряжение отрезков, прямых и лучей применимо даже к параллельным объектам.

Ключи команды FILLET:

□ Undo – отмена предыдущей операции в команде скругления;

□ Polyline – означает, что операция сопряжения выполняется со всей полилинией, строятся дуги сопряжения во всех точках пересечения линейных сегментов двумерной полилинии;

□ Radius – позволяет задать радиус скругления, то есть радиус дуги, соединяющей сопрягаемые объекты;

□ Trim – позволяет определить, следует ли обрезать выбранные кромки по конечным точкам дуги сопряжения;

□ Multiple – скругление углов у нескольких наборов объектов.

Пример. Сопряжение объектов 


Нужно скруглить контуры детали, нарисованные пунктирной линией (рис. 11.15).

 

Рис. 11.15. Сопряжение объектов

 
Запустите команду FILLET, вызвав ее из падающего меню Modify ► Fillet или щелчком на пиктограмме Fillet на панели инструментов Modify. Ответьте на запросы:

_FILLET

Current settings: Mode = TRIM, Radius = 0.5000

Select first object or [Undo/Polyline/Radius/Trim/Multiple]: R – переход в режим указания радиуса скругления

Specify fillet radius <0.5000>: 50 – радиус скругления

Select first object or [Undo/Polyline/Radius/Trim/Multiple]: P – переход в режим сопряжения полилиний

Select 2D polyline: – укажите точку 1

4 lines were filleted

_FILLET

Current settings: Mode = TRIM, Radius = 50.0000

Select first object or [Undo/Polyline/Radius/Trim/Multiple]: R – переход в режим указания радиуса скругления

Specify fillet radius <50.0000>: 20 – радиус скругления

Select first object or [Undo/Polyline/Radius/Trim/Multiple]: – укажите точку 2

Select second object or shift-select to apply corner: – укажите точку 3

_FILLET

Current settings: Mode = TRIM, Radius = 20.0000

Select first object or [Undo/Polyline/Radius/Trim/Multiple]: – укажите точку 4

Select second object or shift-select to apply corner: – укажите точку 5


Глава 12 

Пространство и компоновка чертежа 



Формирование в AutoCAD модели объекта, в том числе трехмерной, обычно не является самоцелью. Это делается для дальнейшего использования такой модели в системах прочностных расчетов и кинематического моделирования, при получении проектно-конструкторской документации, фотографически достоверного изображения готового изделия до его производства, при экспорте трехмерных моделей в другие программы компьютерной графики и т. д. Во всех случаях применения модели необходимо ее отображение либо на экране монитора, либо в виде твердой копии.

В данной главе будут рассмотрены возможности отображения и редактирования моделей в двух пространствах – пространстве модели Model Space и пространстве листа Paper Space, используемых при создании чертежа. Важно понимать, как и когда следует пользоваться пространством листа или модели. Овладев этим инструментом, можно значительно ускорить разработку изделия и повысить производительность.

Обычно в пространстве модели создаются и редактируются модели разрабатываемого объекта, а в пространстве листа формируется отображение этого объекта на плоскости, то есть чертеж с необходимыми графическими изображениями, рамкой чертежного листа, надписями и другой графической информацией, нужной для вывода на плоттер.

В программе AutoCAD каждое окно рисунка разделено на закладки; на одной из них расположена модель, а остальные закладки (может быть одна или несколько) представляют собой аналоги листов бумаги.


Пространство модели и пространство листа 


Пространство модели (Model Space) – это пространство AutoCAD, где формируются модели объектов как при двумерном, так и при трехмерном моделировании. О том, что в окне AutoCAD на текущий момент установлено пространство модели, говорят соответствующая пиктограмма ПСК на рабочем поле чертежа, индикация кнопок Model в нижней части рабочего поля (рис. 12.1) и MODEL в строке состояния. Если пользователь AutoCAD работает только с двумерными объектами, ему нет особой необходимости переходить в пространство листа: все изображения объекта, а также дополнительная информация (рамка формата, размеры, основная надпись и пр.) могут формироваться в пространстве модели.

 

Рис. 12.1. Пиктограмма пользовательской системы координат пространства модели

 
Работа в пространстве модели производится на неперекрывающихся видовых экранах (окнах); там создается основной рисунок или модель.

Пространство листа (Paper Space) – это пространство AutoCAD, необходимое для отображения объекта, сформированного в пространстве модели, на перекрывающихся (плавающих) видовых экранах. Пространство листа облегчает получение твердых копий рисунков и чертежей, разработанных автоматизированным путем. Если бы пространство листа не использовалось, пришлось бы загромождать пространство модели графической информацией, необходимой лишь для формирования чертежных листов. Ведь такие элементы, как рамка чертежного листа, основная надпись и другая графическая и текстовая информация, не имеют отношения к реальной модели и требуются только в распечатке.

Видовой экран (viewport) представляет собой участок графического экрана, на котором отображается некоторая часть пространства модели рисунка.

Пространство листа строго двумерно, и видеть его можно только с точки зрения, перпендикулярной плоскости листа. О том, что в AutoCAD на текущий момент установлено пространство листа, говорят соответствующая пиктограмма ПСК и индикация кнопки PAPER в строке состояния внизу рабочего стола AutoCAD (рис. 12.2).

 

Рис. 12.2. Рабочий стол в пространстве листа

 
В пространстве листа пиктограмма ПСК имеет треугольную форму; располагается она всегда в левом нижнем углу области рисунка.

После создания плавающих видовых экранов вносить изменения в модель можно, переходя с закладки Layout на закладку Model.

Чтобы сделать текущей закладку Model, необходимо щелкнуть на ней кнопкой мыши. Чтобы перейти из этой закладки в пространство листа, достаточно щелкнуть на одной из закладок Layout.

Переключаться между пространствами модели и листа можно также с помощью кнопок MODEL/PAPER в строке состояния.


Видовые экраны 


Как уже говорилось, видовой экран (viewport) представляет собой участок графического экрана, где отображается некоторая часть пространства модели рисунка.

Существует два типа видовых экранов – неперекрывающиеся и перекрывающиеся (рис. 12.3). Неперекрывающиеся видовые экраны располагаются на экране монитора подобно кафельным плиткам на стене. Они полностью заполняют графическую зону и не могут накладываться друг на друга. На плоттер неперекрывающиеся видовые экраны выводятся только поодиночке. Перекрывающиеся видовые экраны подобны прямоугольным окнам, которые располагаются на экране и перемещаются по нему произвольным образом. Эти видовые экраны могут накладываться друг на друга и вычерчиваться одновременно.

 

Рис. 12.3. Примеры неперекрывающихся и перекрывающихся видовых экранов

 

Неперекрывающиеся видовые экраны 


Графическую область в пространстве модели можно разбить на несколько неперекрывающихся видовых экранов, а в пространстве листа создать перекрывающиеся (плавающие) видовые экраны.

Обычно работа с новым рисунком в пространстве модели вначале производится на одном видовом экране, занимающем всю графическую область. Этот видовой экран можно разделить на несколько, выводя на них одновременно различные виды: например, на одном – общий вид, а на другом – вид какого-либо элемента. При этом удобно наблюдать, как редактирование данного элемента отражается на рисунке в целом.

В процессе рисования все изменения, производимые на одном из видовых экранов, немедленно отражаются на остальных. Переключаться с одного видового экрана на другой можно в любой момент, даже в ходе выполнения команды.


Создание нескольких видовых экранов 



Команда VPORTS открывает диалоговое окно Viewports (рис. 12.4). С помощью этой команды графический экран разделяется на несколько неперекрывающихся частей, каждая из которых может содержать отдельный вид рисунка. Команда VPORTS вызывается из падающего меню View ► Viewports ► New Viewports... либо щелчком на пиктограмме Display Viewports Dialog на плавающей панели инструментов Viewports.

 

Рис. 12.4. Диалоговое окно создания видовых экранов

 

Плавающие видовые экраны 


Когда пользователь впервые переключается в пространство листа, графический экран пуст и представляет собой «чистый лист», где будет компоноваться чертеж. В пространстве листа создаются перекрывающиеся (плавающие) видовые экраны, содержащие различные виды модели.

Здесь эти видовые экраны рассматриваются как отдельные объекты, которые можно перемещать и масштабировать, чтобы подходящим образом расположить их на листе чертежа.

В отличие от неперекрывающихся видовых экранов, нет ограничений, разрешающих вывод на плоттер только одного вида пространства модели. Допускается вычерчивать на бумаге любую комбинацию плавающих видовых экранов.

Поскольку плавающие видовые экраны трактуются как самостоятельные объекты, редактировать модель в пространстве листа нельзя. Для получения доступа к ней на плавающем видовом экране необходимо переключиться из пространства листа в пространство модели. Редактирование при этом производится в пределах одного из плавающих видовых экранов.

На рисунке определить, какой из видовых экранов является текущим, можно по находящемуся внутри него перекрестью. Кроме того, о работе в пространстве модели говорит соответствующая форма пиктограммы ПСК. В результате появляется возможность при работе с моделью видеть и скомпонованный лист.

Плавающие видовые экраны создаются и управляются командой MVIEW. Некоторые стандартные конфигурации (включая стандартную конструкторскую с различными видами на каждом видовом экране) вызываются с помощью команды MVSETUP.

Вновь создаваемые плавающие видовые экраны можно расположить в любом месте области рисунка. Как и в случае с неперекрывающимися видовыми экранами, для них допустим выбор одной из стандартных конфигураций.


Видовые экраны произвольной формы 


Удобными представляются возможность создания в пространстве листа непрямоугольных видовых экранов и связывание с видовыми экранами контуров подрезки, благодаря которым их видимая форма может быть любой.

При создании видового экрана произвольной формы обычному видовому экрану ставится в соответствие подрезающий контур – полилиния, окружность, область, сплайн или эллипс.

Допускается модификация уже имеющихся видовых экранов путем переопределения их границ. В качестве новой границы при переопределении можно задать замкнутую полилинию, окружность, сплайн, эллипс, область или дуговой сегмент.

Для создания видовых экранов предназначены два ключа команды -VPORTS – Object и Polygonal.


Object – позволяет преобразовать в видовой экран объект, построенный в пространстве листа. Вызов команды осуществляется из падающего меню View ► Viewports ► Object.

Если выбирается полилиния, она должна быть замкнутой и иметь не менее трех вершин. Допускается наличие в ней сегментов любого типа (как линейных, так и дуговых), а также самопересечения. Полилиния связывается с вновь создаваемым видовым экраном, в результате получается видовой экран неправильной формы. Этот процесс происходит так: AutoCAD описывает прямоугольник вокруг выбранного объекта, создает на его основе прямоугольный видовой экран, а затем «подрезает» его этим объектом.


Polygonal – позволяет описать границу видового экрана путем указания точек-вершин. Последовательность запросов аналогична той, которая используется при построении полилиний. Вызов команды при этом осуществляется из падающего меню View ► Viewports ► Polygonal Viewport.

Как и любые другие объекты, контуры подрезки можно редактировать с помощью ручек.


Глава 13 

Построение трехмерных моделей 



Создание трехмерных моделей – более трудоемкий процесс, чем построение их проекций на плоскости, но при этом трехмерное моделирование обладает рядом преимуществ.

AutoCAD поддерживает три типа трехмерных моделей: каркасные, поверхностные и твердотельные. Каждый из них обладает определенными достоинствами и недостатками. Для моделей каждого типа существует своя технология создания и редактирования.

Поскольку перечисленным типам моделирования присущи собственные методы создания пространственных моделей и способы редактирования, не рекомендуется смешивать несколько типов в одном рисунке.

Каркасная модель представляет собой скелетное описание трехмерного объекта. Она не имеет граней и состоит только из точек, отрезков и кривых, описывающих ребра объекта.

Моделирование с помощью поверхностей – более сложный процесс, чем формирование каркасных моделей, так как в нем описываются не только ребра трехмерного объекта, но и его грани. AutoCAD строит поверхности на базе многоугольных сетей. Поскольку грани сети плоские, представление криволинейных поверхностей производится путем их аппроксимации. Чтобы было проще различать два упомянутых типа поверхностей, под термином «сети» будем понимать те из них, которые составлены из плоских участков.

Моделирование с помощью тел – это самый простой способ трехмерного моделирования. Средства AutoCAD позволяют создавать трехмерные объекты на основе базовых пространственных форм: параллелепипедов, конусов, цилиндров, сфер, клинов и торов (колец). Из этих форм путем их объединения, вычитания и пересечения строятся более сложные пространственные тела. Кроме того, тела можно строить, сдвигая плоский объект вдоль заданного вектора или вращая его вокруг оси.

Твердотельный объект, или тело, представляет собой изображение объекта, хранящее, помимо всего прочего, информацию о его объемных свойствах. Следовательно, тела наиболее полно из всех типов трехмерных моделей отражают моделируемые объекты. Кроме того, несмотря на кажущуюся сложность тел, их легче строить и редактировать, чем каркасные модели и сети.

Модификация тел осуществляется путем сопряжения их граней и снятия фасок. В AutoCAD имеются также команды, с помощью которых тело можно разрезать на две части или получить его двумерное сечение.

Ниже приведены некоторые понятия и определения, принятые в трехмерном твердотельном моделировании:

□ грань – ограниченная часть поверхности;

□ ребро – элемент, ограничивающий грань;

□ полупространство – часть трехмерного пространства, лежащая по одну сторону от поверхности;

□ тело – часть пространства, ограниченная замкнутой поверхностью и имеющая определенный объем;

□ тело (примитив) – наипростейший (основной, базовый) твердотельный объект, который можно создать и строить из него более сложные твердотельные модели;

□ область – часть плоскости, ограниченная одной или несколькими планарными гранями, которые называются границами;

□ область (примитив) – замкнутая двумерная область, которая получена путем преобразования существующих двумерных примитивов, имеющих нулевую высоту, и описана как тело без высоты;

□ составная область – единая область, получаемая в результате выполнения логических операций объединения, вычитания или пересечения нескольких областей;

□ объект – общее наименование области или тел, причем тип объекта не имеет значения: это может быть область, тело или составная модель (группа объектов, связанных в единое целое);

□ пустой объект – составное тело, не имеющее объема, или составная область, не имеющая площади.

Простейшие «кирпичики», из которых строятся сложные трехмерные объекты, называют твердотельными примитивами. К ним относятся ящик (параллелепипед, куб), цилиндр (круговой, эллиптический), шар, тор. С помощью команд BOX, CYLINDER, SPHERE, TORUS, CONE, WEDGE можно создать модели любого из этих тел заданных размеров, введя требуемые значения.

Примитивы заданной формы создаются также путем выдавливания, осуществляемого командой EXTRUDE, или вращения двумерного объекта – командой REVOLVE. Из примитивов получают более сложные объемные модели объектов.

Запускаются все вышеназванные команды из падающего меню Draw ► Modeling или с плавающей панели инструментов Modeling (рис. 13.1).

 

Рис. 13.1. Инструменты для формирования тел

 

Рис. 13.2. Панель рабочих пространств

 
Для трехмерного моделирования удобно использовать рабочее пространство 3D Modeling. Оно устанавливается на панели инструментов Workspaces (рис. 13.2) и включает только необходимые наборы меню, инструментальные панели и палитры, сгруппированные и упорядоченные соответственно решаемой задаче. Элементы интерфейса, не являющиеся необходимыми для решения текущей задачи, скрываются, максимально освобождая область экрана, доступную для работы (рис. 13.3).

 

Рис. 13.3. Рабочее пространство 3D Modeling


Параллелепипед 




Команда BOX формирует твердотельный параллелепипед (ящик, куб). Основание параллелепипеда всегда параллельно плоскости XY текущей ПСК. Команда вызывается из падающего меню Draw ► Modeling ► Box или щелчком на пиктограмме Box на панели инструментов Modeling.

Запросы команды BOX:

Specify first corner or [Center]: – указать первый угол параллелепипеда

Specify other corner or [Cube/Length]: – указать противоположный угол параллелепипеда

Specify height or [2Point]: – указать высоту параллелепипеда

Ключи команды BOX:

□ Center – позволяет сформировать ящик, указав положение его центральной точки;

□ Cube – создает куб, то есть параллелепипед, у которого все ребра равны;

□ Length – создает параллелепипед заданных длины (по оси X), ширины (по оси У) и высоты (по оси Z) текущей ПСК.

Пример. Формирование параллелепипеда 


Постройте параллелепипед (рис. 13.4).

 

Рис. 13.4. Формирование параллелепипеда

 
Запустите команду BOX, вызвав ее из падающего меню Draw ► Modeling ► Box или щелчком на пиктограмме Box на панели инструментов Modeling. Ответьте на запросы:

_BOX

Specify first corner or [Center]: 50,70 – координаты угла параллелепипеда

Specify other corner or [Cube/Length]: 150,200 – координаты другого угла параллелепипеда

Specify height or [2Point]: 80 – высота параллелепипеда


Клин 




Команда WEDGE, формирующая твердотельный клин, вызывается из падающего меню Draw ► Modeling ► Wedge, или щелчком на пиктограмме Wedge на панели инструментов Modeling, или из меню 3D Modeling.

Запросы команды WEDGE:

Specify first corner or [Center]: – указать первый угол клина

Specify other corner or [Cube/Length]: – указать противоположный угол клина

Specify height or [2Point]: – указать высоту Все запросы и ключи команды WEDGE аналогичны запросам и ключам команды BOX.

Пример. Формирование клина 


Постройте клин (рис. 13.5).

 

Рис. 13.5. Формирование клина

 
Запустите команду WEDGE, вызвав ее из падающего меню Draw ► Modeling ► Wedge или щелчком на пиктограмме Wedge на панели инструментов Modeling. Ответьте на запросы:

_WEDGE

Specify first corner or [Center]: 40,50 – координаты угла клина

Specify other corner or [Cube/Length]: 150,180 – координаты противоположного угла клина

Specify height or [2Point]: 100 – высота клина


Конус 




Команда CONE формирует твердотельный конус, основание которого (окружность или эллипс) лежит в плоскости XY текущей системы координат, а вершина располагается по оси Z. Команда вызывается из падающего меню Draw ► Modeling ► Cone, или щелчком на пиктограмме Cone на панели инструментов Modeling, или из меню 3D Modeling.

Запросы команды CONE:

Specify center point of base or [3P/2P/Ttr/Elliptical]: – указать центральную точку основания конуса

Specify base radius or [Diameter]: – указать радиус основания конуса

Specify height or [2Point/Axis endpoint/Top radius]: – указать высоту конуса

Ключи команды CONE:

□ 3Р – строит основание конуса в виде окружности по трем точкам, лежащим на ней;

□ 2P – строит основание конуса в виде окружности по двум точкам, лежащим на диаметре;

□ Ttr – строит основание конуса в виде окружности по двум касательным и радиусу;

□ Elliptical – позволяет создавать основание конуса в виде эллипса;

□ 2Point – указывает, что высотой конуса является расстояние между двумя заданными точками;

□ Axis endpoint – задает положение конечной точки для оси конуса, которой является верхняя точка конуса или центральная точка верхней грани усеченного конуса;

□ Top radius – определяет радиус при вершине усеченного конуса.

Пример. Формирование кругового конуса 


Постройте конус, в основании которого лежит окружность (рис. 13.6).

 

Рис. 13.6. Формирование кругового конуса

 
Запустите команду CONE, вызвав ее из меню Draw ► Modeling ► Cone или щелчком на пиктограмме Cone на панели инструментов Modeling. Ответьте на запросы:

_CONE

Specify center point of base or [3P/2P/Ttr/Elliptical]: 100,100 – центральная точка конуса

Specify base radius or [Diameter]: 80 – радиус основания конуса

Specify height or [2Point/Axis endpoint/Top radius]: 100 – высота конуса


Шар 




Команда SPHERE формирует твердотельный шар (сферу). Для этого достаточно задать его радиус или диаметр. Каркасное представление шара располагается таким образом, что его центральная ось совпадает с осью Z текущей системы координат. Команда вызывается из падающего меню Draw ► Modeling ► Sphere, или щелчком на пиктограмме Sphere на панели инструментов Modeling, или из меню 3D Modeling.

Запросы команды SPHERE:

Specify center point or [3P/2P/Ttr]: – указать центр шара

Specify radius or [Diameter]: – указать радиус шара

Ключи команды SPHERE:

□ 3P – определяет окружность сферы путем задания трех произвольных точек в трехмерном пространстве;

□ 2P – определяет окружность сферы путем задания двух произвольных точек в трехмерном пространстве;

□ Ttr – построение шара по заданному радиусу, касательному к двум объектам.

Пример. Формирование шара 


Постройте шар (рис. 13.7).

 

Рис. 13.7. Формирование шара

 
Запустите команду SPHERE, вызвав ее из падающего меню Draw ► Modeling ► Sphere или щелчком на пиктограмме Sphere на панели инструментов Modeling. Ответьте на запросы:

_SPHERE

Specify center point or [3P/2P/Ttr]: 100,150 – координаты точки центра шара

Specify radius or [Diameter]: 80 – радиус шара


Цилиндр 




Команда CYLINDER, формирующая твердотельный цилиндр, вызывается из падающего меню Draw ► Modeling ► Cylinder, или щелчком на пиктограмме Cylinder на панели инструментов Modeling, или из меню 3D Modeling.

Запросы команды CYLINDER:

Specify center point of base or [3P/2P/Ttr/Elliptical]: – указать центральную точку основания цилиндра

Specify base radius or [Diameter]: – указать радиус основания цилиндра

Specify height or [2Point/Axis endpoint]: – указать высоту цилиндра

Информация, необходимая для описания цилиндра, аналогична той, что используется для описания конуса, поэтому запросы команды CYLINDER совпадают с запросами команды CONE.

Пример. Формирование цилиндра 


Постройте цилиндр, в основании которого лежит окружность (рис. 13.8).

 

Рис. 13.8. Формирование цилиндра

 
Запустите команду CYLINDER, вызвав ее из падающего меню Draw ► Modeling ► Cylinder или щелчком на пиктограмме Cylinder на панели инструментов Modeling. Ответьте на запросы:

_CYLINDER

Specify center point of base or [3P/2P/Ttr/Elliptical]: 200,150 – координаты центральной точки основания цилиндра

Specify base radius or [Diameter]: 140 – радиус основания цилиндра

Specify height or [2Point/Axis endpoint]: 250 – высота цилиндра


Тор 




Команда TORUS формирует твердотельный тор, напоминающий по форме камеру автомобильной шины. При этом необходимо ввести значения радиуса образующей окружности трубы и радиуса, определяющего расстояние от центра тора до центра трубы. Тор строится параллельно плоскости XY текущей системы координат. Команда вызывается из падающего меню Draw ► Modeling ► Torus, или щелчком на пиктограмме Torus на панели инструментов Modeling, или из меню 3D Modeling.

Запросы команды TORUS:

Specify center point or [3P/2P/Ttr]: – указать центр тора

Specify radius or [Diameter]: – указать радиус тора

Specify tube radius or [2Point/Diameter]: – указать радиус полости

Ключи команды TORUS:

□ 3P – задание длины окружности тора по трем точкам;

□ 2P – задание длины окружности тора по двум точкам;

□ Ttr – построение тора по заданному радиусу, касающемуся двух объектов.

Пример. Формирование тора 


Постройте тор (рис. 13.9).

Запустите команду TORUS, вызвав ее из падающего меню Draw ► Modeling ► Torus или щелчком на пиктограмме Torus на панели инструментов Modeling. Ответьте на запросы:

_TORUS

Specify center point or [3P/2P/Ttr]: 100,150 – координаты точки центра тора

Specify radius or [Diameter]: 50 – радиус тора

Specify tube radius or [2Point/Diameter]: 15 – радиус трубы тора

 

Рис. 13.9. Формирование тора

 

Пирамида 



Команда PYRAMID формирует твердотельную пирамиду. Команда вызывается из падающего меню Draw ► Modeling ► Pyramid, или щелчком на пиктограмме Pyramid на панели инструментов Modeling, или из меню 3D Modeling (рис. 13.10).

Запросы команды PYRAMID:

4 sides Circumscribed – текущие значения количества сторон и режима «описанный/вписанный»

Specify center point of base or [Edge/Sides]: – указать центральную точку основания или один из ключей

Specify base radius or [Inscribed]: – указать радиус основания

Specify height or [2Point/Axis endpoint/Top radius]: – указать высоту или один из ключей

Ключи команды PYRAMID:

□ Edge – указывается длина одной кромки основания пирамиды;

□ Sides – задается количество сторон для пирамиды;

□ Inscribed – указывается, что основание пирамиды вписывается в пределах (строится внутри) радиуса основания пирамиды;

□ Circumscribed – указывается, что основание пирамиды описывается вокруг (строится по периметру) радиуса основания пирамиды;

□ 2Point – определяется, что высота пирамиды равняется расстоянию между двумя указанными точками;

□ Axis endpoint – указывается местоположение конечной точки для оси пирамиды;

□ Top radius – указывается верхний радиус пирамиды при создании усеченной пирамиды.

 

Рис. 13.10. Формирование пирамиды

 

Выдавленное тело 




Команда EXTRUDE позволяет создавать твердотельные объекты методом выдавливания двумерных объектов в заданном направлении и на заданное расстояние. Команда вызывается из падающего меню Draw ► Modeling ► Extrude или щелчком на пиктограмме Extrude на панели инструментов Modeling.

Запросы команды EXTRUDE:

Current wire frame density: ISOLINES=4 – текущая плотность каркаса

Select objects to extrude: – выбрать объекты

Select objects to extrude: – нажать клавишу Enter для завершения выбора объектов

Specify height of extrusion or [Direction/Path/Taper angle]: – указать глубину выдавливания

Ключи команды EXTRUDE:

□ Direction – определяет длину и направление выдавливания;

□ Path – позволяет указать высоту и направление выдавливания по заданной траектории;

□ Taper angle – позволяет задать угол сужения конуса для выдавливания.

Допускается выдавливание следующих объектов: отрезков, дуг, эллиптических дуг, двумерных полилиний, двумерных сплайнов, окружностей, эллипсов, трехмерных граней, двумерных фигур, полос, областей, плоских поверхностей, плоских граней на телах.

Команда EXTRUDE часто используется для формирования моделей таких объектов, как шестерни или звездочки.

Траекториями для выдавливания могут быть следующие объекты: отрезки, окружности, дуги, эллипсы, эллиптические дуги, двумерные полилинии, трехмерные полилинии, двумерные сплайны, трехмерные сплайны, грани тел, грани поверхностей, спирали.

Пример. Формирование выдавленного тела 


Постройте твердотельный примитив путем выдавливания; при этом контур для выдавливания должен быть подготовлен заранее (рис. 13.11, 13.12).

 

Рис. 13.11. Контур для формирования выдавленного тела

 
Запустите команду EXTRUDE, вызвав ее из падающего меню Draw ► Modeling ► Extrude или щелчком на пиктограмме Extrude на панели инструментов Modeling. Ответьте на запросы:

_EXTRUDE

Current wire frame density: ISOLINES=8 – текущая плотность каркаса

Select objects to extrude: C – переход в режим выбора объектов секущей рамкой

Specify first corner: – укажите первый угол секущей рамки

Specify opposite corner: – укажите противоположный угол секущей рамки

Select objects to extrude: – нажмите клавишу Enter для завершения выбора объектов

Specify height of extrusion or [Direction/Path/Taper angle]: T – переход в режим определения угла сужения для выдавливания

Specify angle of taper for extrusion: 7 – угол сужения (конусности) граней

Specify height of extrusion or [Direction/Path/Taper angle]: 70 – глубина выдавливания

 

Рис. 13.12. Формирование выдавленного тела

 

Тело вращения 




Команда REVOLVE формирует твердотельные объекты путем вращения существующих объектов или областей на заданный угол вокруг оси X или Y текущей ПСК. Команда вызывается из падающего меню Draw ► Modeling ► Revolve или щелчком на пиктограмме Revolve на панели инструментов Modeling.

Запросы команды REVOLVE:

Current wire frame density: ISOLINES=20 – текущая плотность каркаса

Select objects to revolve: – выбрать объекты для вращения

Select objects to revolve: – нажать клавишу Enter для завершения выбора объектов для вращения

Specify axis start point or define axis by [Object/X/Y/Z] <0bject>: – указать начальную точку оси вращения

Specify axis endpoint: – указать конечную точку оси вращения

Specify angle of revolution or [STart angle] <360>: – указать угол вращения

Ключи команды REVOLVE:

□ Object – требует указания объекта, используемого в качестве оси;

□ X – использует в качестве оси вращения положительную ось X текущей ПСК;

□ Y – использует в качестве оси вращения положительную ось Y текущей ПСК;

□ Z – использует в качестве оси вращения положительную ось Z текущей ПСК.

Можно использовать для вращения следующие объекты: отрезки, дуги, эллиптические дуги, двумерные полилинии, двумерные сплайны, круги, эллипсы, плоские трехмерные грани, двумерные фигуры, полосы, области, плоские грани на телах или поверхностях.

Объект можно вращать вокруг отрезка, линейных сегментов полилинии, двух заданных точек, линейных кромок тел или поверхностей.

Пример. Формирование тела вращения 


Постройте твердотельный примитив путем вращения полилинии вокруг оси. При этом полилиния должна быть подготовлена заранее (рис. 13.13, 13.14).

Запустите команду REVOLVE, вызвав ее из падающего меню Draw ► Modeling ► Revolve или щелчком на пиктограмме Revolve на панели инструментов Modeling. Ответьте на запросы:

_REVOLVE

Current wire frame density: ISOLINES=10 – текущая плотность каркаса

 

Рис. 13.13. Контур и ось для формирования тела вращения

 

Рис. 13.14. Формирование тела вращения

 
Select objects to revolve: – выберите полилинию

Select objects to revolve: – нажмите клавишу Enter для завершения выбора объектов

Specify axis start point or define axis by [Object/X/Y/Z] <Object>: O – переход в режим указания оси вращения объекта

Select an object: – укажите осевую линию

Specify angle of revolution or [STart angle] <360>: – нажмите клавишу Enter, подтверждая вращение на полный круг


Объединение объектов 



Команды, предназначенные для формирования сложных объектов, вызываются из падающего меню Modify ► Solid Editing или с плавающей панели инструментов Solid Editing.


Команда UNION предназначена для объединения объектов и создает сложный объект, который занимает суммарный объем всех его составляющих. Команда позволяет создавать новые составные тела или области из нескольких существующих тел или областей, в том числе не имеющих общего объема или площади (то есть не пересекающихся). Команда вызывается из падающего меню Modify ► Solid Editing ► Union или щелчком на пиктограмме Union на панели инструментов Solid Editing.

Запросы команды UNION:

Select objects: – выбрать объекты Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для завершения работы команды

Пример. Формирование тела путем объединения объектов 


Постройте фигуру, объединив параллелепипед и две сферы (рис 13.15) Запустите команду UNION, вызвав ее из падающего меню Modify ► Solid Editing ► Union или щелчком на пиктограмме Union на панели инструментов Solid Editing. Ответьте на запросы:

_UNION

Select objects: – выберите сферу большего радиуса

Select objects: – выберите сферу меньшего радиуса

Select objects: – выберите параллелепипед

Select objects: – нажмите клавишу Enter для завершения работы команды


Вычитание объектов 




Команда SUBTRACT обеспечивает вычитание одного объекта из другого. Таким образом команда позволяет сформировать новое составное тело или область. Области создаются путем вычитания площади одного набора областей или двумерных примитивов из площади другого набора. Тела создаются путем вычитания одного набора объемных тел из другого подобного набора. Команду можно вызвать из падающего меню Modify ► Solid Editing ► Subtract или щелчком на пиктограмме Subtract на панели инструментов Solid Editing.

 

Рис. 13.15. Формирование тела путем объединения объектов

 
Запросы команды SUBTRACT:

Select solids and regions to subtract from . . – выбрать тела и области, из которых будет выполняться вычитание

Select objects:

Select objects: – нажать клавишу Enter для завершения выбора объектов

Select solids and regions to subtract .. – выбрать тела или области для вычитания

Select objects:

Select objects: – нажать клавишу Enter для завершения работы команды

Пример. Формирование тела путем вычитания объектов 


Постройте фигуру путем вычитания сферы и цилиндра из параллелепипеда (рис. 13.16).

 

Рис. 13.16. Формирование тела путем вычитания объектов

 
Запустите команду SUBTRACT, вызвав ее из падающего меню Modify ► Solid Editing ► Subtract или щелчком на пиктограмме Subtract на панели инструментов Solid Editing. Ответьте на запросы:

_SUBTRACT

Select solids and regions to subtract from ..

Select objects: – выберите параллелепипед

Select objects: – нажмите клавишу Enter для завершения выбора объектов

Select solids and regions to subtract ..

Select objects: – выберите сферу

Select objects: – выберите цилиндр

Select objects: – нажмите клавишу Enter для завершения работы команды


Пересечение объектов 



Команда INTERSECT позволяет при пересечении нескольких существующих объектов создать новые составные тела и области (рис. 13.17). Созданное сложное тело занимает объем, общий для двух или более пересекающихся тел, при этом непересекающиеся части объемов из рисунка удаляются. Команда вызывается из падающего меню Modify ► Solid Editing ► Intersect или щелчком на пиктограмме Intersect на панели инструментов Solid Editing.

 

Рис. 13.17. Формирование тела путем пересечения объектов

 
Запросы команды INTERSECT:

Select objects: – выбрать объекты

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для завершения работы команды


Глава 14 

Редактирование трехмерных объектов 



Команды редактирования в двумерном пространстве, например команды переноса MOVE, копирования COPY, поворота ROTATE, зеркального отображения MIRROR и размножения массивом ARRAY, могут использоваться и в трехмерном пространстве. Кроме того, существуют команды редактирования, применяемые только в трехмерном пространстве, как то: команды поворота, создания массива объектов, зеркального отображения, снятия фаски, скругления.

Команды редактирования трехмерных объектов запускаются из падающего меню Modify ► 3D Operations или с плавающей панели инструментов Modeling (рис. 14.1).


Перенос 



Команда 3DMOVE перемещает объекты на указанное расстояние в заданном направлении, при этом отображает инструмент ручки перемещения в трехмерном виде. Вызывается команда из падающего меню Modify ► 3D Operations ► 3D Move или щелчком на пиктограмме 3D Move на панели инструментов Modeling.

Запросы команды 3DMOVE:

Select objects: – выбрать объекты для переноса

Select objects: – нажать клавишу Enter для завершения выбора объектов

Specify base point or [Displacement] <Displacement>: – указать базовую точку

Specify second point or <use first point as displacement: – указать вторую точку или считать перемещением первую точку

 

Рис. 14.1. Инструменты для редактирования трехмерных объектов

 
Инструмент ручки перемещения отображается в заданной базовой точке. Для ограничения движения перемещением по осям необходимо нажать ручку оси.


Поворот вокруг оси 



Команда 3DROTATE вращает объекты вокруг базовой точки, при этом на трехмерном виде отображает ручку поворота. Вызывается команда из падающего меню Modify ► 3D Operations ► 3D Rotate или щелчком на пиктограмме 3D Rotate на панели инструментов Modeling.

Запросы команды 3DR0TATE:

Current positive angle in UCS: ANGDIR=counterclockwise ANGBASE=0 – текущие установки отсчета углов в ПСК

Select objects: – выбрать объекты для поворота

Select objects: – нажать клавишу Enter для окончания выбора объектов

Specify base point: – указать базовую точку

Pick a rotation axis: – указать ось вращения

Specify angle start point: – указать точку на первом луче угла

Specify angle end point: – указать точку на втором луче угла

Команда ROTATE3D осуществляет поворот объектов в трехмерном пространстве вокруг заданной оси.

Запросы команды ROTATE3D:

Current positive angle: ANGDIR=counterclockwise ANGBASE=0 – текущие установки отсчета углов

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для окончания выбора объектов

Specify first point on axis or define axis by [Object/Last/View/Xaxis/Yaxis/Zaxis/2points]: – указать первую точку оси

Specify second point on axis: – указать вторую точку оси

Specify rotation angle or [Reference]: – указать угол поворота

Ключи команды ROTATE3D:

□ Object – поворот вокруг выбранного объекта;

□ Last – поворот вокруг оси, использовавшейся в предыдущей команде поворота;

□ View – поворот вокруг оси, выровненной вдоль направления вида текущего видового экрана и проходящей через заданную точку;

□ Xaxis, Yaxis, Zaxis – поворот вокруг оси, выровненной соответственно вдоль направления оси X, Y или Z и проходящей через заданную точку;

□ 2point – поворот вокруг оси, проходящей через две заданные точки.


Зеркальное отображение относительно плоскости 



Команда MIRROR3D, осуществляющая зеркальное отображение объектов относительно заданной плоскости, вызывается из падающего меню Modify ► 3D Operations ► 3D Mirror.

Запросы команды MIRROR3D:

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для окончания выбора объектов

Specify first point of mirror plane (3 points) or [Object/Last/Zaxis/View/XY/YZ/ZX/3points] <3points>: – указать первую точку плоскости отражения

Specify second point on mirror plane: – указать вторую точку плоскости отражения

Specify third point on mirror plane: – указать третью точку плоскости отражения

Delete source objects? [Yes/No] <N>: – удалять ли исходные объекты

Ключи команды MIRROR3D:

□ Object – отображение относительно выбранного плоского объекта: отрезка, окружности, дуги или сегмента двумерной полилинии;

□ Last – отображение относительно плоскости, использовавшейся в предыдущей команде отображения;

□ Zaxis – отображение относительно плоскости, заданной двумя точками, первая из которых лежит на плоскости, а вторая определяет вектор нормали к плоскости;

□ View – плоскость отражения ориентируется согласно плоскости взгляда текущего видового экрана, проходящей через указанную точку;

□ XY, YZ, ZX – плоскость отражения ориентируется вдоль одной из стандартных плоскостей (XY, YZ или ZX), проходящей через указанную точку;

□ 3points – отображение относительно плоскости, проходящей через три заданные точки.

Плоскость отображения может представлять собой: плоскость построения двумерного объекта; плоскость, параллельную одной из плоскостей координат (XY, YZ или XZ) текущей ПСК и проходящую через заданную точку; плоскость, определяемую тремя указанными точками.


Размножение трехмерным массивом 



Команда 3DARRAY позволяет создавать прямоугольный и круговой массивы объектов в трехмерном пространстве. Отличие от аналогичной команды, применяемой в двумерном моделировании, состоит в том, что при создании прямоугольного массива объектов кроме количества столбцов и строк запрашивается (задается вдоль направления оси Z) количество уровней, а при создании кругового массива вместо центра вращения используется ось вращения, начальная и конечная точки которой следует указать в ответ на запросы. Команда 3DARRAY вызывается из падающего меню Modify ► 3D Operations ► 3D Array. Запросы команды 3DARRAY:

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для окончания выбора объектов

Enter the type of array [Rectangular/Polar] <R>: – указать тип массива

Enter the number of rows (– ) <1>: – указать число рядов

Enter the number of columns (|||) <1>: – указать число столбцов

Enter the number of levels (...) <1>: – указать число уровней

Specify the distance between rows (– ): – указать расстояние между рядами

Specify the distance between columns (|||): – указать расстояние между столбцами

Specify the distance between levels (...): – указать расстояние между уровнями

Для формирования кругового массива следует выбрать ключ Polar. При этом команда выдает следующие запросы:

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для окончания выбора объектов

Enter the type of array [Rectangular/Polar] <R>: R – выбрать круговой тип массива

Enter the number of items in the array: – указать количество элементов в массиве

Specify the angle to fi ll (+=ccw, -=cw) <360>: – указать угол заполнения

Rotate arrayed objects? [Yes/No] <Y>: – указать, поворачивать ли объекты массива

Specify center point of array: – указать центральную точку массива

Specify second point on axis of rotation: – указать вторую точку оси поворота


Обрезка и удлинение трехмерных объектов 


Любой трехмерный объект можно обрезать либо удлинить до другого объекта независимо от того, лежат ли они оба в одной плоскости и каким кромкам параллельны – режущим или граничным. Чтобы произвести обрезку (удлинение), с помощью системных переменных PROJMODE и EXTEDGE следует выбрать одну из трех проекций: плоскость XY текущей ПСК, плоскость текущего вида или реальное трехмерное пространство.

Чтобы данные операции были выполнены успешно, объекты должны пересекаться с граничными кромками в пространстве, иначе в результате обрезки (удлинения) с проецированием на плоскость XY текущей ПСК новые границы объектов могут не соответствовать указанным кромкам в пространстве.

При вызове команд TRIM и EXTEND, первая из которых выполняет обрезку части объекта по заданной границе, а вторая осуществляет вытягивание до границы в трехмерном пространстве, используется ключ Project, который определяет режим отсечения/вытягивания.


Сопряжение трехмерных объектов 


В AutoCAD можно сопрягать любые объекты, расположенные в одной плоскости и имеющие направления выдавливания, не параллельные оси Z текущей ПСК. Направление выдавливания сопрягающей трехмерной дуги определяется следующим образом:

□ если объекты расположены в одной плоскости и имеют одно направление выдавливания, перпендикулярное ей, сопрягающая дуга лежит в той же плоскости и имеет то же направление выдавливания;

□ если объекты расположены в одной плоскости, но имеют противоположные или вообще различные направления выдавливания, сопрягающая дуга располагается в этой же плоскости. Направление ее выдавливания перпендикулярно плоскости построения объектов; из двух перпендикуляров выбирается ближайший к оси Z текущей ПСК.


Построение сечений 


Команда SECTION осуществляет построение поперечного сечения тела в виде области или неименованного блока. Поперечное сечение – это пересечение плоскости и выбранного тела (рис. 14.2).

 

Рис. 14.2. Формирование сечения

 
Запросы команды SECTION:

Select objects: – выбрать объекты

Select objects: – нажать клавишу Enter для завершения выбора объектов

Specify first point on Section plane by [Object/Zaxis/View/XY/YZ/ZX/3points] <3points>: – указать первую точку на секущей плоскости или один из ключей

Specify second point on plane: – указать вторую точку на плоскости

Specify third point on plane: – указать третью точку на плоскости

Ключи команды SECTION:

□ Object – выравнивание секущей плоскости с сегментом круга, эллипса, круговой или эллиптической дуги, двумерного сплайна или двумерной полилинии;

□ Zaxis – определение секущей плоскости посредством задания двух точек этой плоскости, одна из которых расположена на оси Z;

□ View – проводит секущую плоскость параллельно плоскости вида на текущем видовом экране. Расположение секущей плоскости определяется указанной точкой;

□ XY – выравнивание секущей плоскости с плоскостью XY текущей ПСК;

□ YZ – выравнивание секущей плоскости параллельно плоскости YZ текущей ПСК;

□ ZX – выравнивание секущей плоскости параллельно плоскости ZX текущей ПСК;

□ 3points – задание секущей плоскости по трем точкам.

По умолчанию секущая плоскость задается путем указания трех точек.


Получение разрезов 



Команда SLICE осуществляет построение нового тела путем разрезания какого-либо существующего тела плоскостью (рис. 14.3). Команда вызывается из падающего меню Modify ► 3D Operations ► Slice.

 

Рис. 14.3. Формирование разреза

 
Запросы команды SLICE:

Select objects to slice: – выбрать объекты

Select objects to slice: – нажать клавишу Enter для завершения выбора объектов

Specify start point of slicing plane or [planar Object/Surface/Zaxis/View/XY/YZ/ZX/3points] <3points>: – указать первую точку на режущей плоскости

Specify second point on plane: – указать вторую точку на плоскости

Specify a point on desired side or [keep Both sides] <Both>: – указать точку с нужной стороны от плоскости

Ключи команды SLICE:

□ Object – задает плоскость с помощью выбранного плоского объекта: отрезка, окружности, дуги, эллипса, эллиптической дуги, двумерного сплайна или сегмента двумерной полилинии;

□ Zaxis – задает плоскость двумя точками, первая из которых лежит на ней, а вторая определяет вектор нормали к плоскости;

□ View – задает плоскость, выровненную с плоскостью вида текущего видового экрана и проходящую через заданную точку;

□ XY, YZ, ZX – задают плоскость, выровненную соответственно с плоскостью XY, YZ или ZX и проходящую через заданную точку;

□ 3points – определяет плоскость, проходящую через три заданные точки;

□ keep Both sides – оставляет обе части разрезанного тела.


Преобразование в тело 



Команда CONVTOSOLID преобразует в трехмерные тела полилинии и окружности, для которых задана высота. Команда вызывается из падающего меню Modify ► 3D Operations ► Convert to Solid.

В выдавленные трехмерные тела можно преобразовать следующие объекты:

□ полилинии с равномерной шириной, имеющие высоту;

□ замкнутые полилинии с нулевой шириной, имеющие высоту;

□ окружности, обладающие высотой.

Системная переменная DELOBJ определяет, будут ли выбранные пользователем объекты удалены после создания тела или будет выдана подсказка на удаление объектов.


Преобразование в поверхность 



Команда CONVTOSURFACE преобразует объекты в поверхности. Команда вызывается из падающего меню Modify ► 3D Operations ► Convert to Surface.

В поверхности можно преобразовать следующие объекты: двумерные фигуры; области; разомкнутые полилинии с нулевой шириной, имеющие высоту; отрезки, имеющие высоту; дуги, имеющие высоту; плоские трехмерные грани.


Снятие фасок на гранях 



Команда CHAMFER осуществляет снятие фасок (скашивание) на пересечениях смежных граней тел, как и в двумерном пространстве. Команда вызывается из падающего меню Modify ► Chamfer или щелчком на пиктограмме Chamfer на панели инструментов Modify. При использовании команды необходимо вначале выбрать базовую поверхность, затем ввести размеры фаски и выбрать ребра (рис. 14.4).

 

Рис. 14.4. Пример снятия фаски с тела

 
Запросы команды CHAMFER:

(TRIM mode) Current chamfer Dist1 = 10.0000, Dist2 = 10.0000 – параметры фаски

Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]: – выбрать первый отрезок или один из ключей

Base surface selection... – выбирается базовая поверхность

Enter surface selection option [Next/OK (current)] <OK>: – нажать клавишу Enter, если подсвечена нужная поверхность.

Если требуется другая поверхность, следует ввести N, для того чтобы подсветить смежную поверхность, а затем нажать клавишу Enter

Specify base surface chamfer distance <10.0000>: – указать длину фаски для базовой поверхности

Specify other surface chamfer distance <10.0000>: – указать длину фаски для другой поверхности

Select an edge or [Loop]: – выбрать ребро

Select an edge or [Loop]: – выбрать ребро

Ключи команды CHAMFER:

□ Undo – отменяет предыдущую операцию в команде;

□ Polyline – построение фасок вдоль всей полилинии;

□ Distance – задание длин фасок, то есть расстояний от выбранного пересечения до концов линии фаски;

□ Angle – задание в качестве параметров фаски одной из ее длин и величины угла;

□ Trim – определяет, обрезаются ли выбранные грани по конечным точкам фаски;

□ mEthod – определяет, используются ли для построения фаски значения двух длин или значение длины и величины угла;

□ Multiple – создает фаски для кромок нескольких наборов объектов.


Сопряжение граней 



Команда FILLET осуществляет плавное сопряжение (скругление) граней, как и в двумерном моделировании (рис. 14.5). Для скругления тел можно воспользоваться несколькими способами. Во-первых, так же, как и для плоских объектов, можно задать радиус и затем указать ребра. Второй путь – указать радиус скругления для каждого ребра. И наконец, еще один способ – скруглять последовательность касательных ребер. Команда вызывается из падающего меню Modify ► Fillet или щелчком на пиктограмме Fillet на панели инструментов Modify.

Запросы команды FILLET:

Current settings: Mode = TRIM, Radius = 10.0000 – текущие настройки

Select first object or [Undo/Polyline/Radius/Trim/Multiple]: – выбрать первый объект

Enter fillet radius <10.0000>: – указать радиус сопряжения

Select an edge or [Chain/Radius]: – выбрать ребро

Select an edge or [Chain/Radius]:

Select an edge or [Chain/Radius]: – нажать клавишу Enter для завершения работы команды

 

Рис. 14.5. Пример скругления тела

 
Ключи команды FILLET:

□ Undo – отменяет предыдущую операцию в команде;

□ Polyline – строит дуги сопряжения во всех точках пересечения линейных сегментов двумерной полилинии;

□ Radius – задание радиуса сопрягающей дуги;

□ Trim – определяет, обрезаются ли выбранные кромки по конечным точкам дуги сопряжения;

□ Multiple – скругление углов у нескольких наборов объектов.


Глава 15 

Определение трехмерных видов 



Использование AutoCAD для создания трехмерных моделей и их изображений имеет множество преимуществ по сравнению с применением программы в двумерном моделировании, но вместе с тем требует несколько иного подхода. Работа в трехмерном пространстве представляет собой сочетание рисования, редактирования и установки видов и видовых экранов для изображения модели.

При построении трехмерной модели приходится работать более чем с одним видом объекта. Возможно, что изображение объекта будет достаточно информативным на одном виде и нечитаемым на другом. В любом случае при работе с трехмерными объектами следует установить несколько видовых экранов, например один – с видом в плане, другой – с видом слева, дополнительный – с аксонометрическим видом.

Находясь в пространстве модели, можно рассматривать сформированные объекты с любой точки зрения. Точкой зрения (видом) называется направление, задаваемое из трехмерной точки пространства на начало системы координат. Установка направления взгляда производится в начале работы с моделью или при необходимости рассмотреть завершенную модель из какой-либо конкретной точки. AutoCAD позволяет взглянуть на рисунок из любой точки пространства, даже изнутри изображаемого объекта. Перемещая точку зрения в нужную позицию, удобнее формировать объекты, редактировать их, а также получать изображения со скрытыми линиями, закрашенные и тонированные. Можно получать виды в ортогональной и перспективной проекциях.

С помощью инструментов трехмерного просмотра и навигации можно перемещаться по чертежу, настраивать камеру на определенный вид и создавать анимации для обеспечения параллельного доступа к своему проекту другим пользователям. Можно перемещаться по всей трехмерной модели в режиме движения по кругу, разворота, обхода или облета, настраивать камеру, создавать анимацию предварительного просмотра и записывать анимации траектории перемещения, которые можно передавать другим пользователям для визуального ознакомления с проектом.


Установка ортогональных и аксонометрических видов 


Для установки ортогональных и аксонометрических видов используются инструменты падающего меню View ► 3D Views или с плавающей панели инструментов View (рис. 15.1, 15.2).

 

Рис. 15.1. Падающее меню View

 

Рис. 15.2. Плавающая панель инструментов View

 
Плавающая панель View содержит следующие инструменты:


Named Views… – сохранение и восстановление именованных видов в диалоговом окне View Manager, которое также можно открыть из падающего меню View ► Named Views...;


Top – установка точки зрения сверху (план, горизонтальная проекция);


Bottom – установка точки зрения снизу;


Left – установка точки зрения слева (профильная проекция);


Right – выбор точки зрения справа;


Front – установка точки зрения спереди (фронтальная проекция);


Back – установка точки зрения сзади;


SW Isometric – выбор юго-западного изометрического вида;


SE Isometric – установка юго-восточного изометрического вида;


NE Isometric – установка северо-восточного изометрического вида;


NW Isometric – установка северо-западного изометрического вида;


Create Camera – позволяет включить и установить положения камеры и цели;


Previous View – установка предыдущего вида;


View Control – инструмент позволяет выбрать и установить текущий вид.


Интерактивное управление точкой взгляда 



Команда 3DORBIT активизирует на текущем видовом экране режим интерактивного управления точкой взгляда при работе в трехмерном пространстве. Видом модели в это время можно управлять с помощью мыши. С орбиты может рассматриваться как вся модель, так и ее отдельные объекты. Команда вызывается из падающего меню View ► Orbit ► Constrained Orbit или щелчком на пиктограмме Constrained Orbit на плавающей панели инструментов Orbit или 3D Navigation.

Для того чтобы приступить к вращению вида, нужно нажать кнопку мыши и начать перемещать ее. При этом точка цели остается неподвижной, а положение камеры, то есть наблюдателя, перемещается относительно нее. Пока команда 3D0RBIT активна, редактирование объектов невозможно.


Свободная орбита 



Команда 3DFORBIT активизирует управление интерактивным просмотром объектов в трехмерном режиме, используя неограниченную орбиту, обеспечивающую движение по кругу в любом направлении без привязки к плоскости. При этом точка зрения не ограничена плоскостью XY или осью Z. Команда вызывается из падающего меню View ► Orbit ► Free Orbit или щелчком на пиктограмме Free Orbit на плавающей панели инструментов Orbit или 3D Navigation.

Вид, на котором действует режим орбиты, помечается орбитальным кольцом. Геометрически оно представляет собой большой круг, разделенный на квадранты четырьмя малыми кругами. В процессе выполнения команды неподвижной остается точка, на которую направлен взгляд, то есть точка цели. Позиция наблюдателя (точка камеры) перемещается относительно цели. Считается, что цель в данном случае совмещена с центром орбитального кольца.


Динамическое вращение трехмерной модели 



Команда 3DCORBIT активизирует возможность постоянного вращения вида по орбите и вызывается из падающего меню View ► Orbit ► Continuous Orbit или щелчком на пиктограмме Continuous Orbit на плавающей панели инструментов Orbit или 3D Navigation.

Работая в этом режиме, пользователь нажимает кнопку мыши и задает направление, в котором должен вращаться вид после отпускания кнопки.

Пока команда 3DC0RBIT продолжает работу, никакие другие вводить в командной строке нельзя; также исключается редактирование объектов. Для завершения работы команды необходимо либо нажать клавишу Enter или Esc, либо выбрать пункт Enter из контекстного меню.


Шарнир 



Команда 3DSWIVEL изменяет цель вида в направлении перетаскивания мыши и вызывается из падающего меню View ► Camera ► Swivel или щелчком на пиктограмме Swivel на плавающей панели инструментов Camera или 3D Navigation.

Во время работы команды 3DSWIVEL осуществляется имитация панорамирования камерой в направлении перетаскивания, при этом изменяется направление обзора и можно выполнять шарнирное перемещение камеры в плоскости XY или вдоль оси Z.


Обход чертежа 



Команда 3DWALK интерактивно меняет вид трехмерного чертежа, при этом кажется, что наблюдатель обходит модель. Команда вызывается из падающего меню View ► Walk and Fly ► Walk или щелчком на пиктограмме Walk на плавающей панели инструментов Walk and Fly или 3D Navigation.

Обход всей модели выполняется в текущем видовом экране перемещением в плоскости XY с помощью клавиатуры, круговой осмотр и поворот – с помощью мыши.

При этом открывается палитра локатора положения POSITION LOCATOR (рис. 15.3), в которой отображается вид сверху на положение трехмерной модели при навигации обхода или облета, заданное пользователем на чертеже.

 

Рис. 15.3. Палитра локатора положения

 

Облет чертежа 



Команда 3DFLY интерактивно меняет вид трехмерного чертежа, при этом кажется, что наблюдатель пролетает сквозь модель. Команда вызывается из раскрывающегося меню View ► Walk and Fly ► Fly или щелчком кнопкой мыши на пиктограмме Fly на плавающей панели инструментов Walk and Fly или 3D Navigation.

Облет всей модели, в отличие от обхода, не ограничивается перемещением в плоскости XY, поэтому создается ощущение полета над площадью модели.

Работа с командой 3DFLY аналогична работе с командой 3DWALK.


Камера 



Команда CAMERA устанавливает камеру и положение цели для создания и сохранения трехмерного вида объектов в перспективе и вызывается из падающего меню View ► Create Camera или щелчком на пиктограмме Create Camera на плавающей панели инструментов View.

Запросы команды CAMERA:

Current camera settings: Height=0 Lens Length=50 mm – текущие настройки камеры

Specify camera location: – указать положение камеры Specify target location: – указать положение цели Enter an option [?/Name/LOcation/Height/Target/LEns/Clipping/View/eXit]<eXit>: – указать один из ключей или нажать клавишу Enter для завершения команды

Ключи команды CAMERA:

□?– выводит на экран список определенных в настоящее время камер;

□ Name – присваивает камере имя;

□ LOcation – указывает положение камеры, из которой рассматривается трехмерная модель;

□ Height – изменяет высоту камеры;

□ Target – указывает рассматриваемый целевой объект камеры;

□ LEns – изменяет фокусное расстояние камеры. Чем больше фокусное расстояние объектива, тем ближе поле зрения;

□ Clipping – определяет переднюю и заднюю секущие плоскости и устанавливает их значения;

□ View – устанавливает текущий вид в соответствии с установками камеры;

□ eXit – прерывает команду.

Камеру, установленную на чертеже, можно включать и выключать, использовать ручки для изменения ее местоположения и цели или фокусного расстояния объектива.


Анимация перемещений при обходе и облете 


Анимация перемещений обеспечивает предварительный просмотр любого перемещения, включая обход и облет чертежа. Перед созданием анимации перемещения по траектории необходимо создать образец предварительного просмотра.


Команда ANIPATH сохраняет анимацию вдоль траектории в трехмерной модели, создавая анимационный файл. Вызывается из падающего меню View ► Motion Path Animations…. При этом открывается диалоговое окно анимации траектории перемещения Motion Path Animation (рис. 15.4), которое позволяет настроить следующие параметры:

□ в области Camera – настройка камеры;

□ в области Target – настройка цели;

□ Animation settings – управление выводом анимационного файла;

□ When previewing show camera preview – загрузка диалогового окна предварительного просмотра анимации Animation Preview;

□ Preview… – предварительный просмотр анимации в диалоговом окне предварительного просмотра Animation Preview.

 

Рис. 15.4. Диалоговое окно анимации траектории перемещения

 
Движение камеры управляется привязкой камеры и ее цели к точке или траектории.


Глава 16 

Создание реалистичных изображений 



В процессе проектирования различных объектов большая часть графических работ приходится на формирование каркасных, поверхностных или твердотельных моделей. Отображение объектов на экране дисплея должно происходить быстро, в реальном времени. Как правило, по завершении работы над моделью, а иногда и в процессе проектирования требуется максимально правдоподобное изображение сконструированного объекта, то есть должны быть использованы реальные цвета, специфическая текстура поверхности, естественная светотень, перспектива и другие эффекты. Это бывает необходимо, например, при предъявлении заказчику законченного проекта или при проверке правильности выполнения дизайн-проектирования. Кроме того, визуализация моделей объектов, сформированных в AutoCAD, может быть вполне самоценной, в том числе при создании рекламы или анимационных клипов.

Если перечислять способы отображения моделей объектов в порядке усложнения, последовательность будет такова: изображения в виде трехмерного каркаса; изображения с подавленными скрытыми линиями; изображения с раскрашенными поверхностями; тонированные изображения с поверхностями, которым присвоены цвет и свойства определенных материалов; изображения объекта с заданным освещением.

Решая вопрос о способе представления объекта, следует учитывать, какого качества нужно добиться и сколько времени на это потребуется. Например, для обычного технического отчета вполне подойдет изображение с подавленными скрытыми линиями или раскрашенное. Для презентаций, дизайнерских проектов, рекламы необходимо применять тонирование и подсветку.


Визуальные стили 


Стиль отображения – это набор параметров, который управляет отображением кромок и теней на видовом экране. Управление визуальными стилями осуществляется из па дающего меню View ► Visual Styles или инструментами плавающей панели Visual Styles.

Устанавливать визуальные стили удобно используя меню View рабочего пространства трехмерного моделирования (рис. 16.1).

 

Рис. 16.1. Инструменты управления визуальными стилями

 
В AutoCAD поддерживаются следующие визуальные стили:

 

 
2D Wireframe – двумерный каркас. Объекты представляются в виде отрезков и кривых как кромки граней и тел. Видны растровые и OLE-объекты, также учиты ваются типы и веса линий (рис. 16.2).

 

Рис. 16.2. Визуальный стиль – двумерный каркас

 

3D Wireframe – трехмерный каркас. Объекты представляются в виде отрезков и кривых как кромки граней и тел (рис. 16.3).

 

Рис. 16.3. Визуальный стиль – трехмерный каркас

 

3D Hidden – трехмерный каркас со скрытыми линиями. Объекты представляются в каркасном виде. При этом линии, относящиеся к задним граням, не отображаются (рис. 16.4).

 

Рис. 16.4. Визуальный стиль – трехмерный каркас со скрытыми линиями

 

Realistic – реалистичный. Раскрашиваются объекты и сглаживаются кромки между гранями многоугольника. Отображаются материалы объектов (рис. 16.5).

 

Рис. 16.5. Визуальный стиль – реалистичный

 

Conceptual – концептуальный. Раскрашиваются объекты и сглаживаются кромки между гранями многоугольника. Для раскрашивания используется стиль грани Гуч с переходом не от тени к свету, а между холодным и теплым цветовыми тонами. Этот эффект менее реалистичен, но он лучше отображает подробности модели (рис. 16.6).

 

Рис. 16.6. Визуальный стиль – концептуальный

 
В стилях Realistic и Conceptual грань освещается двумя удаленными источниками, которые перемещаются при изменении направления взгляда на модель.


Подавление линий заднего плана 



Команда HIDE обеспечивает создание рисунка без скрытых линий. Сложные трехмерные модели часто оказываются перегруженными, что затрудняет их чтение и просмотр результатов выполнения какой-либо команды на объекте. Можно устранить эту проблему, подавив скрытые (невидимые с данной точки зрения) линии. Команда HIDE вызывается из падающего меню View ► Hide или щелчком на пиктограмме Hide на плавающей панели инструментов Render.

При подавлении невидимых линий твердотельного объекта генерируются и удаляются невидимые линии объекта, представленного сетью. Например, для сферы силуэтной линией будет окружность. Подавленные скрытые линии остаются невидимыми до тех пор, пока не будет произведено какое-либо действие, вызывающее регенерацию, после чего на экране вновь появится изображение в виде каркасной модели.


Освещение 


Для получения реалистичного тонированного изображения в AutoCAD предоставляется возможность создавать, перемещать и настраивать источники света. Задавая источники света, а также материалы поверхности объектов, можно добиваться всех необходимых эффектов, связанных с цветом, отражением и светотенью.

В AutoCAD имеются следующие виды источников света: удаленные, точечные, прожекторы, а также солнечный свет.

Инструменты создания и настройки источников света находятся в падающем меню View ► Render ► Light или на панелях инструментов Lights и Render.


Назначение материалов 


Чтобы сделать тонированные изображения более правдоподобными, можно придать поверхностям объектов оптические свойства различных материалов. Материалы могут быть как реальными, так и не существующими в природе.

Материалы обычно объединяют в библиотеки для дальнейшего использования. Библиотека AutoCAD содержит более 300 материалов и текстур. Если имеющийся набор не удовлетворяет разработчика, он может сам создать материал, который будет соответствовать его требованиям.


Команда MATERIALS, позволяющая определить материалы, вызывается из па дающего меню View ► Render ► Materials... или щелчком на пиктограмме Materials... на панели инструментов Render. Эта команда выводит на экран палитру Materials, показанную на рис. 16.7.


Рис. 16.7. Диалоговое окно определения материалов

 
В этой палитре настраивается отображение образцов материалов, имеющихся на чертеже, а также редактирование выбранного материала.


Фон 



Для создания фона в текущем виде используют команду VIEW, вызываемую из падающего меню View ► Vamed Views.... При этом загружается диалоговое окно View Manager, в котором необходимо щелкнуть на кнопке New…. В появившемся диалоговом окне создания вида New View, в области Background настраиваются параметры переопределения стандартного фона (рис. 16.8).

 

Рис. 16.8. Диалоговое окно создания вида

 
Диалоговое окно переопределения стандартного фона Background имеет различный список настраиваемых параметров в зависимости от выбранного типа фона: одноцветный сплошной фон; градиентная заливка или использование для определения фона файла с изображением (рис 16.9).

 

Рис. 16.9. Диалоговое окно определения фона с помощью изображения
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